Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot change the brightness of the monitor on a laptop either from the command line or from keyboard shortcuts. I have verified that the file in /sys/class/backlight/acpi_video0/brightness is changing. I have also verified that I am running the nvidia drivers.

Things I have tried:

  1. Adding entries to /etc/default/grub The GRUB_CMDLINE_LINUX_DEFAULT and GRUB_CMDLINE_LINUX entries now read

    GRUB_CMDLINE_LINUX_DEFAULT="quite nosplash acpi_backlight=vendor"
    GRUB_CMDLINE_LINUX="noapic"
    

    I have also tried various commands here (with an update grub and reboot each time) but nothing has helped

  2. I enabled brightness control in /etc/X11/xorg.conf so that it now looks like

    Section "Device"
            Identifier "Default Device"
            Driver "nvidia"
            Option "NoLogo" "True"
            Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    
  3. Investigated installing linux-kamal-mjgbacklight and determined it was not applicable to my system

Nothing seems to have made any difference. I am using an Nvidia GeForce GT 330M with driver version 295.40. Does anyone have any other suggestions?

share|improve this question
    
Can you add the model # of the laptop? –  Jorge Castro Jul 3 '12 at 2:14
add comment

1 Answer 1

Did you enable additional drivers?
If so, disable it, and it works!

You don't need the additional drivers to enable desktop effects and stuff, by installing ccsm you can do all that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.