Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude E6420 laptop plugged into a docking station, and the dock has 2 monitors (connected with DVI).

Also note that I've installed Ubuntu alongside (dual-boot) Windows 7.

I can't get the dual monitors to work both on Ubuntu (either 11.10 or 12.04) and Windows 7.

When I run lspci | grep VGA, I get:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation GF108 [Quadro NVS 4200M] (rev a1)

If I then reboot and uncheck Optimus setting in the BIOS during reboot, I'm able to get the dual monitors to work in Ubuntu 12.04 (but I need to configure them every boot in Nvidia Settings).

When I run lspci | grep VGA, I get: 01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [Quadro NVS 4200M] (rev a1)

But then if I reboot into Windows (leaving the Optimus unchecked), Windows can't detect external monitors, and the resolution is unacceptably low.

I've seen on many forum posts that this particular graphics card setup causes lots of headaches. I haven't been able to resolve my problem yet.

How can I use my external display on my laptop with intel and nvidia video cards?

How to use external displays with Intel driver on a NVidia/Intel hybrid system

nVidia Optimus , Unity 3D and Dual Monitors

"Just use VGA instead of DVI" isn't an option because my dock has only 1 VGA port (and 2 DVI).

Switching the BIOS setting on every reboot and then reconfiguring the display settings every time is tedious, time-consuming, and impractical.

Do you know how to make this work smoothly?

Thanks for your help!

P.S. see also: http://superuser.com/questions/434358/dell-latitude-e6420-dual-boot-ubuntu-windows-7-optimus-graphics-problems

share|improve this question
    
Still loking for an answer in that one too. I guess you already read that the DVI ports are connected to the nvidia card. You can run single applications on the nvidia card using bumblebee. I guess running the whole X-server on the nvidia card would be a solution but I have no idea how to do this. –  André Stannek Aug 24 '12 at 14:01
    
Good news. The new X-server 1.13 has a better support for hybrid graphics if you use it in combination with Linux kernel 3.5. Nvidia is working on drivers that use those features. So there is hope for us. X-server 1.13 and kernel 3.5 will be included .in Ubuntu 12.10. Hope Nvidia finishes the new driver till then –  André Stannek Sep 14 '12 at 12:25

1 Answer 1

Try disabling Optimus in the BIOS and use/install the latest nVidia drivers. If those from the repository don't work, download them from nVidia.

http://www.nvidia.com/object/linux-display-amd64-295.53-driver.html

Please let me know how it goes; I'm about to purchase a E6520 with dock as well.

share|improve this answer
    
I think changing that BIOS setting caused problems in both Windows 7 (I'm dual booting) and Ubuntu. –  Ryan Jun 7 '12 at 21:27
    
Well :-) you can always re-enable Optimus before booting Windows while you're testing. –  Jan Jun 8 '12 at 3:43
    
Thanks, but that is not a practical option as it takes far too long to change all the settings. –  Ryan Jun 8 '12 at 16:34
    
@Ryan if you do not mind power consumption, you can stick to discrete mode. Is that what you want? –  Lekensteyn Jun 8 '12 at 17:51
    
@Lekensteyn Consuming more power is an option if it fixes my problem. How can I use "discrete mode"? Do you just mean uncheck the "Optimus" box? That led to problems mentioned above. Thanks. –  Ryan Jun 8 '12 at 21:51

protected by Community Jun 13 '13 at 7:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.