Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 64-bit, Precise Pangolin, with a PNY GTS 250 1GB video card and a monitor plugged into each of the DVI ports. I'm using the proprietary drivers (post-release updates).

If I set anything to do with Separate X Screens up in nvidia-settings (and write it to xorg.conf and reboot), my second monitor has a grey background, no menu bar, no ability to have a window on it, the second monitor doesn't get picked up in a screneshot, and if I move my mouse cursor to it it's an ugly black X. Plus, my network is unable to connect to anything.

If I subsequently delete /etc/X11/xorg.conf and reboot, everything goes back to working, albeit with a single monitor activated.

If I set anything to do with TwinView up in nvidia-settings, my second monitor starts working, but it isn't seen as a second monitor by Ubuntu, so I can't apply color calibration to it separately. Plus, my mouse gets "caught" between the monitors every time I try to move my cursor between the two.

What gives? If it helps, this is the xorg.conf that nvidia-settings generates for Separate X Screens.

share|improve this question
1  
Well only a fix for your mouse getting stuck between the monitors is to turn off stick edges in display settings –  Seth Hikari Jun 8 '12 at 2:38
    
Thanks for that, I appreciate it--but the larger problem of TwinView causing Display Settings seeing one long monitor instead of two individual monitors remains. I still can't apply color calibration independently unless Ubuntu sees two monitors. –  Kerrick Jun 8 '12 at 3:05
1  
Yes also working on this problem because separate X screens do not work. and Unity does not seem to be in 3D with Twin view. –  Seth Hikari Jun 8 '12 at 3:09
    
Also this is the bug I am sure it is related to bugs.launchpad.net/ubuntu/+source/nautilus/+bug/885989 –  Seth Hikari Jun 8 '12 at 3:10
    
I have same problem except i downloaded the 295.53 driver from nvidia's site. and the display manager has one screen called laptop. im not on a laptop. the nvidia settings knows the monitors. how do we get dual monitors to work? i had display think both monitors was one big one. that the only way i could of had dual monitor till i install this driver. –  Alex Jun 9 '12 at 2:35
add comment

2 Answers 2

After such a struggle with settings here and settings this with the Nvidia graphics GUI I clicked on dash, typed in driver, selected additional driver. Here you should see 2 options after opening addition drivers

NVIDIA accelerated graphics dirver (version current)[Recommended] NVIDIA accelerated graphics dirver (post-release updates)(version current-updates)

I had 1 selected as this is how I installed my Nvidia driver initially (Had trouble downloading directly from the site and installing it). This then broke and after a struggle as mentioned above I selected 2 and clicked on activate, restarted my machine and boom. Up and working np. Here is my xorg.conf file output

Edit: Oh and how to get rid of the mouse getting stuck between the 2 screens:

  1. Dash - Displays
  2. Sticky Edges - Slide to off (this is on by default)
share|improve this answer
1  
Yes, I have tried the version current, but I'm using the version current-updates now. It still won't work correctly. I'll try your xorg.conf file when I get back to my desktop, though. –  Kerrick Jun 14 '12 at 15:21
add comment

This is a known bug in 12.04, after upgrade to 12.04 amd64 Gnome Classic not properly draw second screen

At the time of this writing, it is confirmed and has "Low" priority.

It might be helpful to go to the bug and mark it "This bug affects me…"


I solved this problem by installing Arch Linux with kdm display manager, xfce desktop and compiz with extra plugins.

Now I have two working screens each with working compiz effects (cube. 3D windows).

Also I have different wallpapers on each monitor, not done before.

Also each has fully fictional panels and menus.

It's also very fast. The downside is that if you choke at the terminal, installing it will be a nightmare. Also I had to compile Google chrome but it went without a hitch. I so happy my face hurts from grinning.

A compiz trick was needed, you have to open ccsm on each screen and set screen selector to proper screen.

My two screens: enter image description here enter image description here

share|improve this answer
1  
You realize this is Ask Ubuntu, right? –  Kerrick Jun 27 '12 at 6:40
    
Yes, and not likely to change either. However this is how you get what used to be available in prior releases, and not (yet) available in current release. –  keepitsimpleengineer Jun 27 '12 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.