Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

System: ( lsb_release -a )

Distributor ID: Ubuntu
Description:    Ubuntu 10.04.4 LTS
Release:        10.04
Codename:       lucid

This is my command:

sudo chmod +a "www-data allow delete,write,append,file_inherit,directory_inherit" app/cache app/logs

Docs:

Error:

chmod: invalid mode: `+a'
Try `chmod --help' for more information.

Why doesn't this work? Isn't the +a standard chmod?

UPDATE:

Looks like this is a OSX only mod:

share|improve this question
    
try +x instead of +a –  Ashu Jun 5 '12 at 13:48

2 Answers 2

up vote 8 down vote accepted

"+a" is not a standard argument, no. Follow the next step in the linked documentation.

sudo setfacl -R -m u:www-data:rwx -m u:`whoami`:rwx app/cache app/logs
sudo setfacl -dR -m u:www-data:rwx -m u:`whoami`:rwx app/cache app/logs

Info on what the "+a" does for chmods that use it:

+a The +a mode parses a new ACL entry from the next argument on the commandline and inserts it into the canonical location in the ACL. If the supplied entry refers to an identity already listed, the two entries are combined.

share|improve this answer
    
Thanks, needed to install the setfacl package –  Phill Pafford Jun 5 '12 at 13:57

That is Mac OS X syntax. See here for proof.
Ubuntu's chmod doesn't include this option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.