Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Just installed gnome-shell in my 12.04 box and, unity disappears from the login screen.

This is what I've done trying to fix:

  1. #Exec: unity --reset`
  2. Purge and install: indicator-session
  3. Set Display full username to true in gsettings

`

share|improve this question
    
is it related to this? askubuntu.com/questions/126411/… –  dado_eyad Jun 5 '12 at 12:13
    
I tried "sudo apt-get install indicator-applet-complete" yesterday. By the way, sound applet is working. –  Jhonnytunes Jun 5 '12 at 12:30
add comment

4 Answers

Try this:

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get install --reinstall ubuntu-desktop

If you have compizConfig Setting Manager installed then try

ccsm 
share|improve this answer
    
Let me try that.... –  Jhonnytunes Jun 5 '12 at 11:50
    
Let me know if it works. –  Mitch Jun 5 '12 at 11:53
    
Didnt work, I've exec that command and reboot, username still missing so do the icon of user. –  Jhonnytunes Jun 5 '12 at 12:02
    
Do I have to exec: "ccsm" after "sudo apt-get install --reinstall ubuntu-desktop" ? –  Jhonnytunes Jun 5 '12 at 12:31
    
No, just try that to see if there is any conflicts, and try to resolve them. –  Mitch Jun 5 '12 at 12:33
show 4 more comments

Just open CCSM, scroll down to Desktop, click on Ubuntu Unity Plugin, make sure Enable Unity Plugin is checked in the box on the left side panel of the CCSM window.

enter image description here

That fixed mine. No reboot required.

share|improve this answer
    
There is no such check box in CCSM in 12.04. –  jokerdino Sep 24 '12 at 6:51
    
Yes, there is. See screen-shot. –  Peachy Sep 25 '12 at 13:35
add comment
up vote 1 down vote accepted

Re-Installed ubuntu, the name is missing just because I disable guest-account.

share|improve this answer
add comment

If you were using compizconfig-settings-manager and messed up your desktop. Only thing that worked successfully for me, was repair it with the same program..

  1. Ctrl +Alt+T (To open terminal)
  2. ccsm (To start program.)
  3. Repair what you have messed up.

All other stuff what you can find online, such as

sudo apt-get install --reinstall ubuntu-desktop

haven't give any result. It was just waste of time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.