Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[update: July 28th 2012] After submitting this question, I had some good help from the community a always! - the bug I submitted was never answered by the developers, which left me feeling disappointed, especially as I gave the bulk of money i paid to the developers. For me personally, I don't think I would pay for another wine wrapped game - it has to be native or not all or the wine wrapped game won't be getting my cash! [/update]

I installed LIMBO from the Humble Bundle V and as far as I am aware, this has wine packaged with it (I also installed the latest from the repo's in case is was because of that).

However the game doesn't even start and fails with the message: Wine Program Error Internal errors - invalid parameters received.

Is there a way to log the error or does anyone know why this happens? This question was asked previously but it seems to have disappeared.

My Graphics cards is a Geforece GT 250

Cheers

ice.

[edit: Wine outputs the following error:

wine /opt/limbo/support/limbo/drive_c/Program\ Files/limbo/limbo.exe
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
fixme:win:EnumDisplayDevicesW ((null),0,0x32f580,0x00000000), stub!
err:x11settings:X11DRV_ChangeDisplaySettingsEx No matching mode found 1920x1080x32 @60! (XRandR)
err:xrandr:X11DRV_XRandR_SetCurrentMode Resolution change not successful -- perhaps display has changed?
wine: Unhandled page fault on read access to 0x00000000 at address 0x48213e (thread 0009), starting debugger...

The debugger has the following output:

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x0048213e).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:0048213e ESP:0032f9f4 EBP:0037cdd0 EFLAGS:00010202(  R- --  I   - - - )
 EAX:00000000 EBX:00000000 ECX:00000000 EDX:0037cf4c
 ESI:0037cda8 EDI:0037cdcc
Stack dump:
0x0032f9f4:  0037cda8 0034c708 7bc35120 00000000
0x0032fa04:  0037cda8 0032fa38 0079fc58 00000000
0x0032fa14:  0048b7d4 00000001 0037cdcc 00000001
0x0032fa24:  00000780 00000438 0034c620 00000000
0x0032fa34:  0034c708 0032fa78 007a04e2 00000002
0x0032fa44:  0048c4bc 00000780 00000438 0037cda8
Backtrace:
=>0 0x0048213e in limbo (+0x8213e) (0x0037cdd0)
0x0048213e: movl    0x0(%eax),%edx
Modules:
Module  Address         Debug info  Name (103 modules)
PE    400000-  926000   Export          limbo
PE  10000000-101ff000   Deferred        d3dx9_43
ELF 79bb3000-7b800000   Deferred        libnvidia-glcore.so.295.53
ELF 7b800000-7ba15000   Deferred        kernel32<elf>
  \-PE  7b810000-7ba15000   \               kernel32
ELF 7bc00000-7bcc3000   Deferred        ntdll<elf>
  \-PE  7bc10000-7bcc3000   \               ntdll
ELF 7bf00000-7bf04000   Deferred        <wine-loader>
ELF 7d7e0000-7d7e4000   Deferred        libnvidia-tls.so.295.53
ELF 7d7e4000-7d8bc000   Deferred        libgl.so.1
ELF 7d9d0000-7d9d9000   Deferred        librt.so.1
ELF 7d9d9000-7d9de000   Deferred        libgpg-error.so.0
ELF 7d9de000-7d9f6000   Deferred        libresolv.so.2
ELF 7d9f6000-7d9fa000   Deferred        libkeyutils.so.1
ELF 7d9fa000-7da43000   Deferred        libdbus-1.so.3
ELF 7da43000-7da55000   Deferred        libp11-kit.so.0
ELF 7da55000-7dada000   Deferred        libgcrypt.so.11
ELF 7dada000-7daec000   Deferred        libtasn1.so.3
ELF 7daec000-7daf5000   Deferred        libkrb5support.so.0
ELF 7daf5000-7dafa000   Deferred        libcom_err.so.2
ELF 7dafa000-7db22000   Deferred        libk5crypto.so.3
ELF 7db22000-7dbf1000   Deferred        libkrb5.so.3
ELF 7dbf1000-7dc03000   Deferred        libavahi-client.so.3
ELF 7dc03000-7dc11000   Deferred        libavahi-common.so.3
ELF 7dc11000-7dcd5000   Deferred        libgnutls.so.26
ELF 7dcd5000-7dd13000   Deferred        libgssapi_krb5.so.2
ELF 7dd13000-7dd66000   Deferred        libcups.so.2
ELF 7dd94000-7ddc8000   Deferred        uxtheme<elf>
  \-PE  7dda0000-7ddc8000   \               uxtheme
ELF 7ddc8000-7ddd3000   Deferred        libxcursor.so.1
ELF 7ddd4000-7dde7000   Deferred        gnome-keyring-pkcs11.so
ELF 7de47000-7de4d000   Deferred        libxfixes.so.3
ELF 7deac000-7ded6000   Deferred        libexpat.so.1
ELF 7ded6000-7df0a000   Deferred        libfontconfig.so.1
ELF 7df0a000-7df1a000   Deferred        libxi.so.6
ELF 7df1a000-7df1e000   Deferred        libxcomposite.so.1
ELF 7df1e000-7df27000   Deferred        libxrandr.so.2
ELF 7df27000-7df31000   Deferred        libxrender.so.1
ELF 7df31000-7df37000   Deferred        libxxf86vm.so.1
ELF 7df37000-7df3b000   Deferred        libxinerama.so.1
ELF 7df3b000-7df5d000   Deferred        imm32<elf>
  \-PE  7df40000-7df5d000   \               imm32
ELF 7df5d000-7df64000   Deferred        libxdmcp.so.6
ELF 7df64000-7df85000   Deferred        libxcb.so.1
ELF 7df85000-7df9f000   Deferred        libice.so.6
ELF 7df9f000-7e0d3000   Deferred        libx11.so.6
ELF 7e0d3000-7e0e5000   Deferred        libxext.so.6
ELF 7e0e5000-7e178000   Deferred        winex11<elf>
  \-PE  7e0f0000-7e178000   \               winex11
ELF 7e178000-7e18e000   Deferred        libz.so.1
ELF 7e18e000-7e228000   Deferred        libfreetype.so.6
ELF 7e228000-7e247000   Deferred        libtinfo.so.5
ELF 7e247000-7e269000   Deferred        libncurses.so.5
ELF 7e27d000-7e292000   Deferred        xinput1_3<elf>
  \-PE  7e280000-7e292000   \               xinput1_3
ELF 7e292000-7e2a6000   Deferred        psapi<elf>
  \-PE  7e2a0000-7e2a6000   \               psapi
ELF 7e2a6000-7e304000   Deferred        dbghelp<elf>
  \-PE  7e2b0000-7e304000   \               dbghelp
ELF 7e304000-7e391000   Deferred        msvcrt<elf>
  \-PE  7e320000-7e391000   \               msvcrt
ELF 7e391000-7e4c5000   Deferred        wined3d<elf>
  \-PE  7e3a0000-7e4c5000   \               wined3d
ELF 7e4c5000-7e4fe000   Deferred        d3d9<elf>
  \-PE  7e4d0000-7e4fe000   \               d3d9
ELF 7e4fe000-7e573000   Deferred        rpcrt4<elf>
  \-PE  7e510000-7e573000   \               rpcrt4
ELF 7e573000-7e67b000   Deferred        ole32<elf>
  \-PE  7e590000-7e67b000   \               ole32
ELF 7e67b000-7e697000   Deferred        dinput8<elf>
  \-PE  7e680000-7e697000   \               dinput8
ELF 7e697000-7e6d1000   Deferred        winspool<elf>
  \-PE  7e6a0000-7e6d1000   \               winspool
ELF 7e6d1000-7e7c9000   Deferred        comctl32<elf>
  \-PE  7e6e0000-7e7c9000   \               comctl32
ELF 7e7c9000-7e833000   Deferred        shlwapi<elf>
  \-PE  7e7e0000-7e833000   \               shlwapi
ELF 7e833000-7ea44000   Deferred        shell32<elf>
  \-PE  7e840000-7ea44000   \               shell32
ELF 7ea44000-7eb23000   Deferred        comdlg32<elf>
  \-PE  7ea50000-7eb23000   \               comdlg32
ELF 7eb23000-7eb3c000   Deferred        version<elf>
  \-PE  7eb30000-7eb3c000   \               version
ELF 7eb3c000-7eb9c000   Deferred        advapi32<elf>
  \-PE  7eb50000-7eb9c000   \               advapi32
ELF 7eb9c000-7ec59000   Deferred        gdi32<elf>
  \-PE  7ebb0000-7ec59000   \               gdi32
ELF 7ec59000-7ed99000   Deferred        user32<elf>
  \-PE  7ec70000-7ed99000   \               user32
ELF 7ef99000-7efa6000   Deferred        libnss_files.so.2
ELF 7efa6000-7efc0000   Deferred        libnsl.so.1
ELF 7efc0000-7efec000   Deferred        libm.so.6
ELF 7efee000-7eff4000   Deferred        libuuid.so.1
ELF 7eff4000-7f000000   Deferred        libnss_nis.so.2
ELF b7411000-b7415000   Deferred        libxau.so.6
ELF b7415000-b741e000   Deferred        libnss_compat.so.2
ELF b741f000-b7424000   Deferred        libdl.so.2
ELF b7424000-b75ca000   Deferred        libc.so.6
ELF b75cb000-b75e6000   Deferred        libpthread.so.0
ELF b75e9000-b75f2000   Deferred        libsm.so.6
ELF b75fa000-b773c000   Dwarf           libwine.so.1
ELF b773e000-b7760000   Deferred        ld-linux.so.2
ELF b7760000-b7761000   Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) Z:\opt\limbo\support\limbo\drive_c\Program Files\limbo\limbo.exe
    00000009    0 <==
0000000e services.exe
    00000020    0
    0000001f    0
    00000019    0
    00000018    0
    00000017    0
    00000015    0
    00000010    0
    0000000f    0
00000012 winedevice.exe
    0000001d    0
    0000001a    0
    00000014    0
    00000013    0
0000001b plugplay.exe
    00000021    0
    0000001e    0
    0000001c    0
00000022 explorer.exe
    00000023    0
System information:
    Wine build: wine-1.4
    Platform: i386
    Host system: Linux
    Host version: 3.2.0-24-generic-pae
share|improve this question

5 Answers 5

This problem seems to be related with setting fullscreen resolution for LIMBO with a different framerate than supported,(51Hz was listed in the output of xrandr for 1920x1080 resolution while the game tries to set it to 60Hz).

  • You can try to edit the file /opt/limbo/support/limbo/drive_c/Program\ Files/limbo/settings.txt and change the parameter backbufferheight = 1080 to adjust it to current display size.
  • If that does not work, try launching the game in windowed mode by changing the parameter as windowedmode = true and possibly decreasing the backbufferheight = 720 or like.
share|improve this answer
    
Unfortunately, that did not work. I still get the same error upon launch from wine. –  icedfusion Jun 5 '12 at 16:08
    
launch the game from the command-line by wine limbo.exe then edit the question with the output. –  Samik Jun 5 '12 at 16:10
    
So, from the first set of errors, I am wondering if it is because I have a dual screen - they are both running at the correct resolution that limbo is trying to change to. –  icedfusion Jun 6 '12 at 19:49
    
Yes, it looks like what you said, just to check, what does xrandr -q says? –  Samik Jun 6 '12 at 19:55
    
icedfusion@ice:~$ xrandr -q xrandr: Failed to get size of gamma for output default Screen 0: minimum 1920 x 1080, current 3840 x 1080, maximum 3840 x 1080 default connected 3840x1080+0+0 0mm x 0mm 3840x1080 50.0* 1920x1080 51.0 52.0 2944x1080 51.0 –  icedfusion Jun 6 '12 at 20:33

I had the same problem with my dual monitor setup. One workaround that was successful for me was to completely disable the secondary monitor (for instance using the nvidia-settings dialog). This may help you until a real fix is provided by CodeWeaver.

share|improve this answer

Per Jeffrey Rosen (Humble Bundle co-founder) via omgubuntu:

The LIMBO Linux build was created by CodeWeavers who basically take a custom version of Wine and tune the game to make sure it runs flawlessly.

This is our first experiment with CodeWeavers and we are watching carefully.

If there are any bugs with the game, I don’t want people to think “oh well, it uses Wine” – these ought to be sent to CodeWeavers who should do their best to fix them.

So, if someone here can help, that's great, but if you can figure out how, giving the details to Codeweavers might be the most helpful.

Unfortunately, it's not easy to submit bugs.

LIMBO is here: http://www.codeweavers.com/compatibility/browse/name/?app_id=9528 .

It redirects you to the support page. It expects you to have bought the actual crossover product, for the most part. I encourage people to poke around there if you've got time -- we might be able to bug them sufficiently to get a better communication channel open if nothing else.

I did find a related report in the codeweavers forums .

share|improve this answer
    
Sorry, didn't know that, this thread must have bumped to active thread due to my edit, I apologise. –  Samik Jun 6 '12 at 22:07
    
No need to apologize -- I only saw this item recently, and if someone can get you up and running here, that's also fine. –  belacq Jun 6 '12 at 22:48
    
Thanks for the info, I spent ages looking at how to submit a bug to codeweavers but couldn't find anything. I ended up emailing humble bumble people who gave me a link to a google bug page. I have submitted the issue and am yet to receive a response, I will test the solution as suggested by samik and report back. –  icedfusion Jun 7 '12 at 11:16
    
@icedfusion What was the google bug link? –  belacq Jun 8 '12 at 18:18
    
For submitting bugs:goo.gl/kmUUd –  icedfusion Jun 16 '12 at 20:15

Okay, I've found a "workaround" of sorts. It involves disabling pulseaudio and loading alsa instead. To do that I followed this article. I then uninstalled Limbo and reinstalled the earlier version. Voila! Game works. Sound works.

share|improve this answer

I also had the issue of Limbo not starting with the same error message: "Internal errors - invalid parameters received"

I have dual monitors with an Nvidia graphics card.

For me, the fix was editing the file: sudo gedit /opt/limbo/support/limbo/drive_c/Program\ Files/limbo/settings.txt

and changing windowmode to true: windowedmode = true

Game works fine now. Thanks Samik

share|improve this answer
    
goo.gl/kmUUd –  icedfusion Jun 16 '12 at 20:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.