Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Macbuntu for my Ubuntu 10.04. The theme is nice and cool.

I want to change the font size to larger. I open the 'Appearance' preference, I find Macbuntu changed the font of system to 'Lucida Grande'.

alt text

However I can't find the 'Lucida Grande' in the font list, so I can't change the font size from 9 to 12.

alt text

Could anybody give me a hint how to change the font size for 'Lucida Grande'?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

This seems like a bug, you should probably file a bug report.

But to answer your question, you could do this graphically (using gconf-editor) but the font settings are spread all over in the gconf database, so the fastest way is to use the command line utility gconftool to change these settings:

Application font:

gconftool --set /desktop/gnome/interface/font_name --type=string "Lucida Grande 12"

Document font:

gconftool --set /desktop/gnome/interface/document_font_name --type=string "Lucida Grande 12"

Desktop font:

gconftool --set /apps/nautilus/preferences/desktop_font --type=string "Lucida Grande 12"

Window title font:

gconftool --set /apps/metacity/general/titlebar_font --type=string "Lucida Grande 12"

Fixed width font:

gconftool --set /desktop/gnome/interface/monospace_font_name --type=string "Lucida Console 12"
share|improve this answer

Just copy the fonts that come with the MacBuntu package to the .fonts/ directory located in your home directory.

share|improve this answer
    
Unfortunately, I don't know where Macbuntu put the font file. –  Kane Nov 24 '10 at 7:41
    
Well, as I do know, there's a "font" directory that comes with the MacBuntu package. –  palindrome Nov 24 '10 at 8:56
    
I find those fonts after copying them into ~/.fonts. Thanks. –  Kane Nov 24 '10 at 9:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.