Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to install dependencies for dropbox, and I found apt trying to remove some quite important packages... Note that in the remove section there is compiz or vim... How to proceed, safely, with the apt? I use Ubuntu 12.04 LTS

$ sudo apt-get -f install 

Reading package lists... Done Building dependency tree       Reading state
information... Done Correcting dependencies... Done The following packages
were automatically installed and are no longer required:

  libunity6 librbd1 gir1.2-gmenu-3.0 msr-tools libaio1
  gir1.2-gnomekeyring-1.0 seabios syslinux-legacy librados2 libxenstore3.0
  gtk3-engines-unico cpu-checker gir1.2-appindicator3-0.1 ebtables libvirt0
  libgmime2.6-cil vgabios libgtkspell-3-0 libnuma1 gir1.2-gudev-1.0
  gir1.2-wnck-3.0 cgroup-lite gir1.2-launchpad-integration-3.0 qemu-utils
  bridge-utils libvirt-bin librsync1 activity-log-manager-common
  qemu-common libgtk2.0-0:i386 libgdk-pixbuf2.0-0:i386 libcairo2:i386
  libpango1.0-0:i386 libthai0:i386 libatk1.0-0:i386 libxft2:i386
  libpixman-1-0:i386 libjasper1:i386 libxcb-render0:i386 libxcb-shm0:i386
  libdatrie1:i386

Use 'apt-get autoremove' to remove them.  The following extra packages will
be installed:

  libatk1.0-0:i386 libcairo2:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386
  libgtk2.0-0:i386 libjasper1:i386 libpango1.0-0:i386 libpixman-1-0:i386
  libpython3.2 libthai0:i386 libxcb-render0:i386 libxcb-shm0:i386
  libxft2:i386 python3 python3-minimal python3-uno python3.2
  python3.2-minimal

Suggested packages:

  librsvg2-common:i386 gvfs:i386 libjasper-runtime:i386 ttf-baekmuk:i386
  ttf-arphic-gbsn00lp:i386 ttf-arphic-bsmi00lp:i386
  ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386 python3-doc python3-tk
  python3.2-doc

The following packages will be REMOVED:

  activity-log-manager-control-center aisleriot alacarte apparmor
  apparmor-utils apport apport-gtk apt-xapian-index aptdaemon apturl
  apturl-common bluez bluez-alsa bluez-gstreamer checkbox checkbox-gtk
  checkbox-qt command-not-found compiz compiz-gnome compiz-plugins-main
  compiz-plugins-main-default compizconfig-backend-gconf computer-janitor
  computer-janitor-gtk deja-dup dropbox:i386 duplicity eog evolution
  evolution-data-server evolution-exchange evolution-indicator
  evolution-plugins evolution-webcal firefox firefox-globalmenu
  firefox-gnome-support foo2zjs foomatic-db-compressed-ppds gconf-editor
  gconf2 gdb gdm gedit gir1.2-peas-1.0 gir1.2-rb-3.0 gir1.2-totem-1.0
  gir1.2-ubuntuoneui-3.0 gksu gnome-applets-data gnome-bluetooth
  gnome-control-center gnome-doc-utils gnome-exe-thumbnailer gnome-media
  gnome-menus gnome-orca gnome-panel-data gnome-search-tool gnome-sudoku
  gnome-terminal gnome-terminal-data gnome-user-share gstreamer0.10-gconf
  guake gwibber gwibber-service gwibber-service-facebook
  gwibber-service-identica gwibber-service-twitter hplip hplip-data ibus
  ibus-pinyin ibus-table indicator-datetime indicator-power ipython
  jockey-common jockey-gtk landscape-client-ui-install
  language-selector-common language-selector-gnome launchpad-integration
  libbonoboui2-0 libcanberra-gtk-module libcanberra-gtk3-module
  libcompizconfig0 libevolution libfolks-eds25 libgksu2-0 libgladeui-1-11
  libgnome-media-profiles-3.0-0 libgnome-vfs2.0-cil libgnome2-0
  libgnome2-common libgnome2.24-cil libgnomeui-0 libgnomevfs2-0
  libgnomevfs2-common libgweather-3-0 libgweather-common libgwibber-gtk2
  libgwibber2 libmetacity-private0 libpeas-1.0-0 libpurple-bin libpython2.7
  libreoffice-gnome librhythmbox-core5 libsyncdaemon-1.0-1 libtotem0
  libubuntuoneui-3.0-1 light-themes lsb-release metacity metacity-common
  nautilus-share network-manager-gnome nvidia-common onboard oneconf
  openoffice.org-gnome openprinting-ppds pitivi printer-driver-foo2zjs
  printer-driver-ptouch printer-driver-pxljr printer-driver-sag-gdi
  printer-driver-splix ptouch-driver pxljr python python-appindicator
  python-apport python-apt python-apt-common python-aptdaemon
  python-aptdaemon-gtk python-aptdaemon.gtk3widgets
  python-aptdaemon.gtkwidgets python-aptdaemon.pkcompat python-brlapi
  python-cairo python-central python-chardet python-configglue
  python-configobj python-crypto python-cups python-cupshelpers
  python-dateutil python-dbus python-debian python-debtagshw
  python-decorator python-defer python-dirspec python-egenix-mxdatetime
  python-egenix-mxtools python-gconf python-gdbm python-gi python-gi-cairo
  python-glade2 python-gmenu python-gnome2 python-gnomekeyring
  python-gnupginterface python-gobject python-gobject-2 python-gst0.10
  python-gtk-vnc python-gtk2 python-gtksourceview2 python-gtkspell
  python-httplib2 python-ibus python-imaging python-impacket
  python-indicate python-keyring python-launchpad-integration
  python-launchpadlib python-lazr.restfulclient python-lazr.uri
  python-libproxy python-libvirt python-libxml2 python-louis python-mako
  python-markupsafe python-minimal python-notify python-oauth
  python-openssl python-packagekit python-pam python-pcapy python-pexpect
  python-piston-mini-client python-pkg-resources python-problem-report
  python-protobuf python-pyatspi2 python-pycurl python-pygoocanvas
  python-pyinotify python-pyorbit python-qt4 python-qt4-dbus python-rdflib
  python-renderpm python-reportlab python-reportlab-accel python-serial
  python-simplegeneric python-simplejson python-sip python-smbc
  python-software-properties python-speechd python-support python-telepathy
  python-twisted-bin python-twisted-core python-twisted-names
  python-twisted-web python-ubuntu-sso-client python-ubuntuone-client
  python-ubuntuone-control-panel python-ubuntuone-storageprotocol
  python-uno python-urlgrabber python-virtkey python-vte python-wadllib
  python-webkit python-wnck python-wsgi-intercept python-xapian python-xdg
  python-xkit python-zeitgeist python-zope.interface python2.7
  python2.7-minimal rastertosag-gdi rhythmbox rhythmbox-mozilla
  rhythmbox-plugin-cdrecorder rhythmbox-plugin-magnatune
  rhythmbox-plugin-zeitgeist rhythmbox-plugins rhythmbox-ubuntuone
  sessioninstaller software-center software-center-aptdaemon-plugins
  software-properties-common software-properties-gtk splix
  system-config-printer-common system-config-printer-gnome
  system-config-printer-udev tomboy totem totem-mozilla totem-plugins
  ttf-mscorefonts-installer ubuntu-artwork ubuntu-desktop ubuntu-minimal
  ubuntu-sso-client ubuntu-sso-client-gtk ubuntu-sso-client-qt
  ubuntu-standard ubuntu-system-service ubuntuone-client
  ubuntuone-client-gnome ubuntuone-control-panel
  ubuntuone-control-panel-common ubuntuone-control-panel-gtk
  ubuntuone-control-panel-qt ubuntuone-couch ubuntuone-installer ufw
  unattended-upgrades unity unity-2d unity-common unity-lens-applications
  unity-lens-video unity-place-applications unity-scope-musicstores
  unity-scope-video-remote update-manager update-manager-core
  update-notifier update-notifier-common usb-creator-common usb-creator-gtk
  vim vim-gnome virt-manager virtinst xdiagnose xul-ext-ubufox zeitgeist
  zeitgeist-core zeitgeist-datahub zeitgeist-extension-ftsa

The following NEW packages will be installed:

  libatk1.0-0:i386 libcairo2:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386
  libgtk2.0-0:i386 libjasper1:i386 libpango1.0-0:i386 libpixman-1-0:i386
  libpython3.2 libthai0:i386 libxcb-render0:i386 libxcb-shm0:i386
  libxft2:i386 python3 python3-minimal python3-uno python3.2
  python3.2-minimala

WARNING: The following essential packages will be removed.  This should NOT
be done unless you know exactly what you are doing!  python-minimal
python2.7-minimal (due to python-minimal) 0 upgraded, 18 newly installed,
312 to remove and 0 not upgraded.  1 not fully installed or removed.  Need
to get 10.1 MB of archives.  After this operation, 333 MB disk space will
be freed.  You are about to do something potentially harmful.  To continue
type in the phrase 'Yes, do as I say!'
share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I suggest to completely remove (purge) dropbox, then reinstall following these instructions: https://www.dropbox.com/install?os=lnx

I did it on my system (12.04 LTS too) and have no issues with sudo apt-get -f install

share|improve this answer
    
I had to apt-get purge virtualbox-4.1:i386 dropbox:i386, then I was able to do update, autoremove and -f –  Jakub M. Jun 5 '12 at 8:27
add comment

Do you know if you recently removed any major metapackages such as ubuntu-desktop? (You could have manually done this...or it could have happened automatically as a result of removing a dependency of the metapackage.)

In particular, is ubuntu-desktop installed? If not, installing it may mark the needed packages as being required by a manually installed package, making them no longer subject to autoremoval.

share|improve this answer
    
ubuntu-desktop is installed (dpkg -l gives ii ubuntu-desktop). Although, I removed kvm recently, can that be the cause? –  Jakub M. Jun 5 '12 at 8:13
    
@JakubM. Sorry, of course it is, it's listed as one of the packages to be removed by apt-get autoremove. If you were to set it to manually installed (and do the same with ubuntu-minimal), that might protect many of the important packages from being subject to autoremoval. (You can set a package to manually installed the same way you'd manually install it: sudo apt-get install ubuntu-desktop ubuntu-minimal.) I don't know if this will fix your whole problem, or even if this operation will succeed (depending on what's broken on your system), but it shouldn't hurt. –  Eliah Kagan Jun 5 '12 at 8:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.