Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed assault cube from the Software centre and it just opens for half a second and closes. When i run in it from the terminal, this is what i get -

d@d-platform:~$ assaultcube
Using home directory: /home/d/.assaultcube_v1.104
current locale: en_IN
init: sdl
init: net
init: world
init: video: sdl
init: video: mode
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  129 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0xb3
  Serial number of failed request:  131
  Current serial number in output stream:  133
share|improve this question

2 Answers 2

Install the package x11proto-xf86vidmode-dev by sudo apt-get install x11proto-xf86vidmode-dev and then retry launching the game.

share|improve this answer
    
Thanks for the help but it was still not working. Then I tried running in windowed mode (-t) and it worked. Any ideas what the issue might be with my computer? –  Debashis Pradhan Jun 7 '12 at 6:13
    
well, from the error message you provided previously, it looks like the header file for X protocol (/usr/include/X11/Xproto.h) lacks the operation performed with opcode 129 which is XFree86-VidModeExtension, so I suggested you to install that package. –  Samik Jun 7 '12 at 8:28

With a clue from here I was able to fix mine. open it up with the -t option from the terminal, then go to options and go to display, there you uncheck v-sync. after that you can set it to full screen and apply. it works. even works after closing and opening the program.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.