Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am using Ubuntu 12.04. I use a wired connection. My network MAC address shows as 00:00:00:00:00:00.

When I enter the commands below into a terminal window, it starts working again.

sudo ifconfig eth0 down
sudo ifconfig eth0 hw ether my mac address
sudo ifconfig eth0 up

I have to enter these commands every time I want to use the Internet. How can I fix this?


Update copied from comment

The contents of my /etc/NetworkManager/NetworkManager.conf file is:

[main] 
plugins=ifupdown,keyfile 
dns=dnsmasq 
no-auto-default=00:00:00:00:00:00,

[ifupdown] 
managed=false
share|improve this question

marked as duplicate by qbi, Florian Diesch, Eric Carvalho, Seth, Uri Herrera Feb 25 '13 at 2:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Take a look at this askubuntu.com/questions/74575/… –  Mitch Jun 5 '12 at 5:40
    
I know my Mac address. When I put it in network connections nothing happens. I think that some bug has made 00:00:00:00:00:00 my default mac address. –  user57184 Jun 5 '12 at 13:44
add comment

1 Answer 1

Could you clarify exactly what you mean when you say that your MAC is 00:00:00:00:00:00.

What happens when you open the menu for Unity's Network Indicator, select Edit Connections, and then click on the Edit button for the Wired connection?

Do you see 00:00:00:00:00:00 as the only possible value for Device MAC address? (See example in the third (last) screenshot below.)

screenshot of Network Indicator's menu

screenshot of Network Connections settings window

screenshot of edit window for Wired connection settings


For whatever it is worth, the contents of my NetworkManager.conf file differs from yours. I do not have the entry no-auto-default=00:00:00:00:00:00,.

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false

Below is an excerpt from the online documentation for the NetworkManager configuration file describing no-auto-default.

Set devices for which NetworkManager shouldn't create default wired connection (Auto eth0). NetworkManager creates a default wired connection for any wired device that is managed and doesn't have a connection configured. List a device in this option to inhibit creating the default connection for the device.

I am not sure that the no-auto-default entry is the cause of your problem. But you could still try the following just to rule it out.

  • Create a backup copy of the file. One way to do this would be by using the copy command below.

    cd /etc/NetworkManager
    sudo cp NetworkManager.conf NetworkManager.conf.backup
    
  • Use a text editor, for example gedit, to edit NetworkManager.conf and delete the no-auto-default line to see if it makes a difference.

    sudo gedit /etc/NetworkManager/NetworkManager.conf
    
share|improve this answer
    
I am new to ubuntu. Networkmanager conf file in etc/networkmanager is like this [main] plugins=ifupdown,keyfile dns=dnsmasq no-auto-default=00:00:00:00:00:00, [ifupdown] managed=false I can type my mac address in network connections. When I save it nothing happens. It shows 00:00:00:00:00:00 as an option and when I click on it save option gets disabled. –  user57184 Jun 6 '12 at 3:46
    
@user57184 Would you please verify that using the GUI configuation windows give you the same results. If any changes were made, the GUI should almost certainly have been updated to work correctly since that would be considered to be the way most people would change their settings. –  irrational John Jun 6 '12 at 4:09
    
How to create a back up copy of Networkmanager.conf? –  user57184 Jun 6 '12 at 6:40
    
@irrationalJohn - please remove the questions in your answer. Remember to use comments to ask for further details. –  fossfreedom Jun 6 '12 at 8:56
    
@user57184 - this is a Q&A site. Please keep editing your question with important information such as the above - comments is not the best please for this type of info. Thanks. –  fossfreedom Jun 6 '12 at 8:57
show 4 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.