Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I tried to upgrade my server to ubuntu 12.04, it gave this message, but the upgrade process will continue :

 WARNING:root:estimate_kernel_size_in_boot() returned '0'?

This is a VPS server on openvz. I just upgraded from 11.04 to 11.10 without any problems. But what to do now?

share|improve this question
Can you access a shell? – Mitch Jun 5 '12 at 3:58
@Mitch Yes its working. I tried to upgrade through it. I didn't upgrade to 12.04... cancelled it after seeing the error! – THpubs Jun 5 '12 at 4:00
Can you include the output of sudo fdisk -l – Mitch Jun 5 '12 at 4:03
@Mitch It says "cannot open /proc/partitions" – THpubs Jun 5 '12 at 4:06
Do you have other OS's on you system – Mitch Jun 5 '12 at 4:09
up vote 5 down vote accepted

But what to do now?

Continue. The warning is expected, since OpenVZ VPSs do not have their own kernels -- they operate on the physical host's kernel. OpenVZ is more like an enhanced chroot rather than a true virtual machine in that respect.

Important - if your running kernel is less than 2.6.24

Please check your current kernel version with uname -r. If it is less than 2.6.24, the upgrade will fail half-way with a glibc error. That happens because the glibc included by default with 12.04 requires a minimum 2.6.24 kernel -- glibc are the critical C libraries used by every application.

At that point, you will need the instructions [from this answer], as pasted below:

I've set up a PPA containing a recompiled libc which is compiled to work on 2.6.18 or newer (please check uname -r!), and it should override the current libc provided by Precise. Just add ppa:izx/ovz-libc, update, and it should let you get past this. Specifically, something like this:

apt-add-repository ppa:izx/ovz-libc
apt-get update
apt-get -f install

and continue on until the upgrade completes successfully. I highly recommend NOT replacing any changed or non-existent config files.

I will be keeping the ppa updated as and when libc is updated upstream. The PPA package includes a pin so that it will only be updated when the new fixed libc is available on the PPA, not when it first appears in the official repositories.

share|improve this answer
It worked but it took my server offline :P There were some issues with openvz and 12.04. Thanks to my host's support, we fixed it :D – THpubs Jun 5 '12 at 7:58
Just gave this a go but I'm still getting gcc errors when trying to run apt-get -f install: gcc: /lib/ version `GLIBC_2.14' not found (required by gcc) – nurikabe Feb 20 '13 at 20:38
This PPA didn't work for Virtuozzo at least. Testing from Ubuntu 10.04 to 12.04 it fails to me with: "/lib/ version `GLIBC_2.14' not found (required by locale)" – shakaran Aug 15 '13 at 9:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.