Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a 32-bit server, running at 3.03 Ghz, 2gb RAM & 512 L2 Cache. Whenever I try to install Ubuntu 11.10 or 12.04, after installing the Base System, we get to Setting up Users and Passwords, then Configuring the package manager, which fails everytime. I've tried everything I can think of, but nothing seems to work. Any suggestions of what is wrong and how to fix it? Thanks.

share|improve this question
you sure the ISO's are fine ? – Raja Jun 5 '12 at 2:53
What ISO image are you using? You should give that information, as that can be different even for same architecture. The x32 desktop version of the installer has a bug. How does it fail? Do you have internet connection working for the machine? – Anders Jun 6 '12 at 10:07

2 Answers 2

Had the same problem with 12.04 LTS. My workaround was to wait for the disk partitioning phase, and then to open a console with Alt+F2.

Edit /usr/lib/apt-setup/generators/50mirror.ubuntu and comment out the two lines with db_metaget and db_subst statements after the comment "Text is variable for Debian". No idea why this breaks the installation, but it does.

share|improve this answer
Spent two days on this. Ubuntu 12.10 x64. Wrote iso to usb stick with 5 different methods, always hanged at this step. The weird thing was that i could ping the system, but it showed no video output. And since i had no ssh installed.. i had a working stable ubuntu server that did nothing all day long and couldn't been connected to in any way. For future reference: i also had the cant find cd error - solved by running mount /dev/sdX /cdrom (where x is the usb stick device). If i could i would give you thousand points, not just one! Thank you for sharing this!! – vlad b. Dec 9 '12 at 19:08
I install Ubuntu 13.10 x64 server. This problem place there too. – StXh Oct 20 '13 at 2:20
ubuntu-14.04.1-server-amd64 has the same issue, and this solution helps. Thanks! – lordvlad Sep 24 '14 at 11:36
+1 for posting solution. how do you found the solution? – ChillarAnand Oct 11 '14 at 9:23

TO others that have this issue, run the installer through text version. If it gets stuck on a file for too long (or time keeps going up and down) just press enter and then Ignore and it will skip it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.