Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.04 amd64 The last thing I see before this message is ubuntu boot splash screen.

The hardware configuration is:

  • Gigabyte 970a-ud3 motherboard
  • AMD Phenom II X4 975 processor
  • 8 GB RAM
  • NVIDIA Corporation GT200 [GeForce GTX 260]

I've tried to remove xorg.conf, but nothing have changed. And now I have no idea about what should I do to make it work.

Here's an excerpt from /var/log/Xorg.0.log that seems to make sense.

[    13.956] (==) Matched nvidia as autoconfigured driver 0
[    13.956] (==) Matched nouveau as autoconfigured driver 1
[    13.956] (==) Matched nv as autoconfigured driver 2
[    13.956] (==) Matched vesa as autoconfigured driver 3
[    13.956] (==) Matched fbdev as autoconfigured driver 4
[    13.956] (==) Assigned the driver to the xf86ConfigLayout
[    13.956] (II) LoadModule: "nvidia"
[    13.956] (WW) Warning, couldn't open module nvidia
[    13.956] (II) UnloadModule: "nvidia"
[    13.956] (II) Unloading nvidia
[    13.956] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    13.956] (II) LoadModule: "nouveau"
[    13.957] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    13.957] (II) Module nouveau: vendor="X.Org Foundation"
[    13.957]    compiled for 1.11.3, module version = 0.0.16
[    13.957]    Module class: X.Org Video Driver
[    13.957]    ABI class: X.Org Video Driver, version 11.0
[    13.957] (II) LoadModule: "nv"
[    13.957] (WW) Warning, couldn't open module nv
[    13.957] (II) UnloadModule: "nv"
[    13.957] (II) Unloading nv
[    13.957] (EE) Failed to load module "nv" (module does not exist, 0)
[    13.957] (II) LoadModule: "vesa"
[    13.957] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    13.957] (II) Module vesa: vendor="X.Org Foundation"
[    13.957]    compiled for 1.11.3, module version = 2.3.0
[    13.957]    Module class: X.Org Video Driver
[    13.957]    ABI class: X.Org Video Driver, version 11.0
[    13.957] (II) LoadModule: "fbdev"
[    13.957] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    13.957] (II) Module fbdev: vendor="X.Org Foundation"
[    13.957]    compiled for 1.11.3, module version = 0.4.2
[    13.957]    ABI class: X.Org Video Driver, version 11.0
[    13.957] (==) Matched nvidia as autoconfigured driver 0
[    13.957] (==) Matched nouveau as autoconfigured driver 1
[    13.957] (==) Matched nv as autoconfigured driver 2
[    13.957] (==) Matched vesa as autoconfigured driver 3
[    13.957] (==) Matched fbdev as autoconfigured driver 4
[    13.957] (==) Assigned the driver to the xf86ConfigLayout
[    13.957] (II) LoadModule: "nvidia"
[    13.958] (WW) Warning, couldn't open module nvidia
[    13.958] (II) UnloadModule: "nvidia"
[    13.958] (II) Unloading nvidia
[    13.958] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    13.958] (II) LoadModule: "nouveau"
[    13.958] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    13.958] (II) Module nouveau: vendor="X.Org Foundation"
[    13.958]    compiled for 1.11.3, module version = 0.0.16
[    13.958]    Module class: X.Org Video Driver
[    13.958]    ABI class: X.Org Video Driver, version 11.0
[    13.958] (II) UnloadModule: "nouveau"
[    13.958] (II) Unloading nouveau
[    13.958] (II) Failed to load module "nouveau" (already loaded, 0)
[    13.958] (II) LoadModule: "nv"
[    13.958] (WW) Warning, couldn't open module nv
[    13.958] (II) UnloadModule: "nv"
[    13.958] (II) Unloading nv
[    13.958] (EE) Failed to load module "nv" (module does not exist, 0)
[    13.958] (II) LoadModule: "vesa"
share|improve this question
    
What version of Ubuntu are you running? What version of the nVidia driver did you install? Support for your hardware was added in 280.13 so you will need at least Oneiric to use it. –  Chris Jun 5 '12 at 2:28
    
I use ubuntu 12.04. I edited the question, thanks. –  zetdotpi Jun 5 '12 at 9:13
    
Can you try sudo apt-get remove nvidia-current nvida-current-updates nvidia-settings from terminal followed by sudo mv /usr/X11/xorg.conf /usr/X11/xorg.conf.nvidia.old and see what happens. You will need to reboot. This should drop you back to the nouveau drivers. If that works, you can try to reinstall the nvidia-current-updates driver from Additional Hardware. Let me know how it pans out. –  Chris Jun 5 '12 at 21:22
    
I've tried it already, but nothing changed. Everything is exactly the same. –  zetdotpi Jun 6 '12 at 1:27
    
That's too bad. Do you have /etc/modprobe.d/nvidia-current-updates_hybrid.conf or /etc/modprobe.d/nvidia-graphics-drivers.conf or anything similare in /etc/modprobe.d that could be blacklisting nouveau? –  Chris Jun 6 '12 at 2:47
show 5 more comments

1 Answer

Select the default ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

Press DOWN ARROW until you get to the line that starts with

linux /boot

and press END keys to position your cursor at the end of the that line usually ending with “quiet splash”.

Now type in the additional kernel option nomodeset (please dont make the same typing error I made for this screenshot :-)

Nomodeset

share|improve this answer
    
Unfortunately, this didn't help. –  zetdotpi Jun 5 '12 at 11:21
    
What is the nomodeset option supposed to do? I have a somewhat similar issue and I'm looking for alternative solutions (see Nvidia X Server flickers, hangs and segfaults on start-up). –  landroni Jan 11 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.