Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bumped to a huge (for me) problem. I was running dual boot system (win 7 / linux) and at some point I decided to test fedora ( I am new in Linux ).

My hard disk conf: 3 hard disks each 1 TB, 2 set to raid 0 with windows running on it and 1 for linux. After installing it from live usb I found out that windows 7 is not in grub anymore and while booting shows raid error. I installed back Ubuntu and ran Disk Utility and checked now I have one disks (raid 0) failed (READ) error. First has 5 bad sectors and second has 1 bad sector. And now I dont know what to do and how to repair. further I dont know which data i could provide to get help.

I tried ntfsfix and got this output:

Mounting volume... NTFS signature is missing.
FAILED
Attempting to correct errors... NTFS signature is missing.
FAILED
Failed to startup volume: Invalid argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk.


#sudo ntfs-3g -o force,rw /dev/sdb /media/windows
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
share|improve this question
    
this is my disk with error: Disk /dev/sdb doesn't contain a valid partition table –  Hiawatha Jun 5 '12 at 1:13
    
added my comments to question. Thanks for tip Eliah Kagan. –  Hiawatha Jun 5 '12 at 1:53
    
If you add the info from the first comment, then that comment could be removed too (I'm not doing it myself because I'm not sure how you want to present that information). –  Eliah Kagan Jun 5 '12 at 2:00
add comment

1 Answer 1

You need to (re)install GRUB to the RAID device instead of the block device. This is documented in the Ubuntu Documentation though the documentation is a little old and can be confusing. The errors you encounters are correct because the filesystem is installed on the RAID device not the block device[*].

RAID (actually FakeRAID) devices are named /dev/mapper/[something] instead of /dev/sd[X]. First you will need to find the RAID device for your windows partition with ls /dev/mapper/. This will list all of the active devices. Since you presumably only have one, it should be easy to find. If the device is not listed, the dmraid man page will explain how to activate your RAID device. This is usually done with sudo dmraid -ay as root.

Once you know the device name, you can (re)install GRUB with sudo grub-install /dev/mapper/[something]. GRUB setup should detect Windows, and Ubuntu. Reboot to test.

[*]This is not technically correct as the underlying filesystem is actually installed on the block device. In modern versions of Ubuntu is is masked by the raid device to mimic the way the device is mounted in windows. If this were RAID 1 instead of RAID 0 you could disable RAID in the BIOS and you would see two drives with identical filesystems on them. Since this is RAID 0 the filesystem is split between the two.

share|improve this answer
    
Alternatively, you could try to install GRUB to the third (non-RAID) disk. If GRUB install detects windows on the raid device you should be able to boot. I have never tried this, but it should work. –  Chris Jun 5 '12 at 3:49
    
# ls /dev/mapper/ control # dmraid -r /dev/sda: isw, "isw_cjhggchbgj", GROUP, ok, 1953525166 sectors, data@ 0 # dmraid -ay -f isw ERROR: isw: wrong number of devices in RAID set "isw_cjhggchbgj_Vol" [1/2] on /dev/sda RAID set "isw_cjhggchbgj_Vol" was not activated so what ever function I try it says wrong number of devices in RAID. Actually I dont care about grub, only data on the RAID 0 part of the disks. I cant use any datarecovering tools because there I have some unbackuped projects so I would have thousands of files.. without mapstructure (I know, was stupid to not backup) –  Hiawatha Jun 5 '12 at 9:55
    
when I used Disk Utility on raid disks I have Failed (READ) error... dont know whether it has to do with raid 0 option... or my HD's are giving up... –  Hiawatha Jun 5 '12 at 9:58
    
Unfortunately, this is the real limitation with RAID 0. Because the filesystem is written across both devices and different blocks of single files are spread between the two, a failure in one device is mostly a failure of both. This is somewhat by design as your system can write 1/2 of the blocks to one device while synchronously (almost) writing to the other, performance is increased. What make are your hard disks? You might be able to use the manufacture's recovery tools to check the disks. It is a long shot, but worth a try if there is a lot of data at stake. –  Chris Jun 5 '12 at 21:08
    
If all of the data on the third disk is replaceable, you might try to copy the data from the "bad" disk to the third disk and restore the array. This might save some of the data. The instructions on the Ubuntu Community Wiki may be helpful here. –  Chris Jun 5 '12 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.