Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just started using ubuntu a few months ago and recently upgraded from 11.10 to 12.04.

After a few minutes of watching any video online (StumbleUpon video, YouTube and others), I get a black screen. I am unable to do anything, but reboot at this point (to my limited knowledge).

So far, I've tried updating the Adobe Flash plugin via Flash Aid (Firefox Add-on), but that doesn't seem to have worked.

share|improve this question

closed as too localized by Bruno Pereira Jun 11 '12 at 8:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

This should do the trick:

sudo apt-get install ubuntu-restricted-extras

Additionally,you can view youtube videos with HTML5 technology without using Flash,which will solve your problem and prevent crashes.

share|improve this answer
    
Almost worked. The difference is that the videos play for much longer before the black screen appears. Also, I notice that the laptop heats up a lot when a flash video is playing, and that's when the black screen appears. –  rahi Jun 5 '12 at 17:14
    
Right.That happens only with videos or with any other flash application?(Like a flash game for example).Does youtube in HTML5 work? –  Nickolas Jun 5 '12 at 17:20
    
You may also try running this command in terminal sudo apt-get purge flashplugin-installer –  Nickolas Jun 5 '12 at 17:21
    
It appears to be just videos. I just tried a flash game and no crash fortunately. The HTML5 on YouTube is enabled, and not crashing at the moment. The purge flashplugin returned this in the terminal: Package flashplugin-installer is not installed, so not removed. –  rahi Jun 5 '12 at 17:43
    
you could try installing it by typing sudo apt-get install flashplugin-installer –  Nickolas Jun 5 '12 at 17:46

This is a bit rash, but resolved with a fresh install of 12.04.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.