Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I succesfully installed my Canon Pixma MP150 printer (and scanner) in Ubuntu 12.04, made it the default printer, but i cannot print anything. Watching the printing queue, i see that the printer receives my documents but just for a few seconds after which the queue gets empty without anything getting actually printed.

I tried to print from large pdf's to quite tiny txt files. I reinstalled the printer from cups web-based interface (127.0.0.1:631) but again, no luck.

Any ideea on the matter?

share|improve this question
    
Look at the CUPS tab labeled Administration. On the right side of the screen, under the heading Server, there should be a button to View Error Log. Click that and see if there are messages to help determine exactly what the problem is. –  Tim Jun 5 '12 at 13:56

2 Answers 2

Install the printer in cups-browserinterface as mp140 with the mp150 driver. That used to be the driver in all the previous ubuntu´s.

This has solved my problems wich sounds exactly like yours.

share|improve this answer

I simply re-installed the driver like this:

  • In the Printer Configuration window, right-click on your Printer and select Properties
  • Then in the Settings Tab, modify the driver by selecting the right device, and erase the old driver with the new.

Don't need to restart, it works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.