Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having this problem.

Tried this:

$ unity --reset

This command hangs up on 'Setting Update "run_key"'

Also tried this:

$ ccmd

Unity plugin was disabled. I enabled it and rebooted. But still no luck.

Also tried this:

$ rm -rf ~/.config/compiz-1/compizconfig/*
$ rm -rf .compiz-1
$ sudo apt-get purge compizconfig-settings-manager

Nothing happened.

Also tried this:

$ sudo apt-get install --reinstall ubuntu-desktop

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/3,928 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 164812 files and directories currently installed.)
Preparing to replace ubuntu-desktop 1.267 (using .../ubuntu-desktop_1.267_amd64.deb) ...
Unpacking replacement ubuntu-desktop ...
Setting up ubuntu-desktop (1.267) ...

It didn't work.

Any ideas?

share|improve this question

closed as too localized by Bruno Pereira Jun 25 '12 at 21:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Try this:

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get install --reinstall ubuntu-desktop
share|improve this answer
It didn't work =/ – HappyDeveloper Jun 4 '12 at 19:24
If that did not work, then take a look at this… – Mitch Jun 4 '12 at 19:32
Nothing works. Seems like a plugin is missing or something, and it breaks everything. I need something more drastic. Installing ubunt-desktop took a lot of time the first time (I installed from server edition) but I wouldn't care as long as I don't have to reinstall from live CD and lose my files. But this time with the '--reinstall' parameter it took just a second, not what I expected. Any ideas? – HappyDeveloper Jun 4 '12 at 20:20
up vote 0 down vote accepted

I ended up reinstalling the whole system.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.