Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im with Ubuntu 12.04 - Dell Inspiron 5110 (8g ram, i7 cpu). When I connect to a router at my place, i get an internal IP i can ping others in the network (and the router), but have no internet. I trided by checking with trough FF, IE and Opera and couldn't load any pages. I read all other similar topics and nothing helped.

share|improve this question
    
Do you still experience this issue? –  Braiam Jan 21 at 23:29
add comment

2 Answers

Check if DHCP server is giving you nameservers. In terminal window type:

cat /etc/resolv.conf

My resolv.conf:

# Generated by NetworkManager
nameserver 192.168.0.1

If not, the simply solution is adding nameservers by hand. However, if you experience this, you have a problem in DHCP Server.

share|improve this answer
    
It happened again :(. Actually the problem is quite weird, because in Windows my Internet is perfect and in ubuntu i get up to 10000ms ping to the router. I tried pinging 8.8.8.8 - the same story (up to 1s - but it responds). Now I'll restart to Ubuntu and check this command. –  Martin Jun 5 '12 at 8:14
    
I'm in Ubuntu but now it's OK Oo. I will type this command when it breaks again –  Martin Jun 5 '12 at 8:20
    
it returned nameserver 127.0.0.1 and there was a message telling not to edit the file because the content will be overwritten –  Martin Jun 5 '12 at 12:08
1  
Ok. put this in /etc/network/interfaces : dns-nameservers [IP address(es) of your DNS] dns-search [your dns-search strings (optional)] –  Subv3rsion Jun 5 '12 at 12:11
    
I found out that when this problem occurs - I actually can browse to google.com but with extremely high latency. My ping to router is 2-10k ms. Seems something is interrupting my wifi connection. However when I connect trough Windows my ping to the router is about 20-100ms And my Internet becomes a bit slower as well. Is there way to define a different channel in Ubuntu to work like in Windows or something like this. –  Martin Jun 6 '12 at 7:51
add comment

This sounds exactly like a DNS problem. In order to really fix your problem though you really out to have stated what desktop environment you are using because some desktop environments like KDE have their own slutions to problems like this. Since you didn't state which one you are using I'm going to assume you are using Unity(since it's already installed by default).

First off, check with any other program that you have installed uses the internet, like a game etc. and see if that program/game can indeed access the internet. If it can even though Internet browsers "cannot", it might even be as simple as a proxy being set on when you don't need to use a proxy. In your browsers settings try turning off proxys and see if that solves the issue.

If not, then it could in fact be a DNS problem. I suggest opening the Terminal and type: dpkg-reconfigure resolvconf and see if that solves your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.