Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did a do-release-upgrade. During the process I was asked if I wanted to replace my rsync config file in init.d with the new version or keep the existing one. I hit D to look at the diff and then could not get back to the question / install script. I stupidly hit ctrl c and was not returned to the upgrade process but to the shell.

I am now worried I have a broken install :( What should I do?

share|improve this question
You can run again, do-release-upgrade to restart the release upgrade. – Octávio Filipe Gonçalves Jun 4 '12 at 11:31
The answers here did not work for me. I found another one here… that worked much better. – Alexis Wilke Oct 7 '12 at 16:32
This worked for me: sudo rm /var/lib/dpkg/lock && sudo dpkg --configure -a (close to what I found in ) – Adam Monsen Jul 12 '14 at 4:18

Your /etc/apt/sources.list was most probably changed to the new version at the point you aborted the upgrade. This will make do-release-upgrade or apt-get dist-upgrade behavior unpredictable.

  • Change it first with (assuming you were upgrading from 11.10):

    sudo sed -i -e 's/precise/oneiric/g' /etc/apt/sources.list

  • Then do a sudo apt-get update followed by a do-release-upgrade.

share|improve this answer

You can run again do-release-upgrade to restart the release upgrade.

The release upgrade, will start from the beginning, again.

share|improve this answer
Depending on how far you made it through the upgrade process, this may not work, and you'll have to edit sources.list – Jordan Apr 9 '15 at 7:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.