Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new computer and I installed Ubuntu 12.04. With Ubuntu 11.10, I had a really awesome periodic table program that I got from the Ubuntu Software Center. When I tried to download it on 12.04 from the software center, it would not download.

It's called Periodic table of elements and the description is A Mendeleiev table of the chemical elements.

share|improve this question
    
It's called 'Periodic table of elements' and the description is 'A Mendeleiev table of the chemical elements' –  Bridget Jun 4 '12 at 9:55

4 Answers 4

Which program are you talking about? I have both installed in 12.04 and have no issues..

enter image description here

How are you doing it? Is it giving you any errors?

Try this way:

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get update && sudo apt-get install gcu-bin

And see if it works.

Try this, Go into Update Manager, and click on the Settings Button

enter image description here

Then click on the Ubuntu Software Tab and go to Download from, and choose other as shown

enter image description here

and then choose Select Best Server.

enter image description here

Once its done try installing the program again.

share|improve this answer
    
It's the third one down. It said to check my internet connection, however my internet connection is fine. –  Bridget Jun 4 '12 at 9:57
    
I ran that command and at the very end it says, "100% [Connecting to archive.ubuntu.com]" –  Bridget Jun 4 '12 at 10:05
  1. First confirm that you are able to browse other websites.

  2. Then, run these commands:

    sudo mv /var/lib/apt/lists{,bakjune4}
    sudo mv /var/cache/apt/archives/partial{,bakjune4}
    sudo apt-get update
    sudo apt-get upgrade
    
  3. If above commands run successfully fine you can remove the above bakjune4 directories safely. Otherwise change the download server using Update Manager. Follow this: Update Manager -> Settings -> Ubuntu Software (first tab) -> Change the server in Download from box. Run check for updates and install updates if any.

Note:
In any case you can revert to your current situation by using following commands:

sudo rm -r /var/lib/apt/lists /var/cache/apt/archives/partial/
sudo mv /var/lib/apt/list{bakjune4,}
sudo mv /var/cache/apt/archives/partial{bakjune4,}
share|improve this answer
    
@Eliah Kagan Thanks for formatting the answer. :-) –  drake01 Jun 5 '12 at 10:26

I recommend just getting the package name from below the title and then using apt-get.

share|improve this answer
    
This answer would be even more useful it you were to explain how to install software with apt-get (to someone who has never used it and doesn't necessarily know what a terminal is). –  Eliah Kagan Jun 5 '12 at 8:23

The package name can be found below the description of the application (first part of the version and above the size). For the 3rd one in that list "Periodic table of the elements" it is gcu-bin.

Open terminal: ctrl-t

To see all options and info about apt-get type

apt-get --help - you can use that argument on many command for info.

To install gcu-bin type (you need root access so proceed with sudo):

sudo apt-get install gcu-bin

press y+enter when asked something

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.