Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Recently I upgraded the Mythbuntu 10.10 to 12.04 which uses Xfce, and realised there is no one click volume adjusting sound applet with a slider, like in 10.10.

Is there something else to do this? Or is Xfce becoming even more minimalist?

share|improve this question
What version of Xfce do you have? – Mitch Jun 4 '12 at 8:36
I am using Xubuntu (12.04), which provides the sound applet as a part of the Indicator Plugin. Click on the panel --> Panel --> Add New Items and look if its there. – 0xf3f Jun 13 '12 at 18:49

6 Answers 6

It's possible to use the standard GNOME volume control.

If you add gnome-sound-applet to your application startup list (it's in the Sessions and Startup settings dialogue in standard Xfce) then it will appear in the notifications area along with network-manager, dropbox and other applets.

share|improve this answer

I believe the standard xfce sound control app on the task bar now works by way of the mouse wheel (or on my laptop the scrolling bit at the side of the finger mouse pad thing or whatever it's called), while the mouse pointer is over it? also I think I read that you can add a slider that appears when you click on it somehow. Sorry I don't have the details.

share|improve this answer
also if you use pulseaudio you must have pavucontrol installed and change the setting 'left-click command' to 'pavucontrol' in the preferences. hope this helps – user63872 Jun 21 '12 at 23:14

In addition to Tom's answer, if you add:

bash -c "XDG_CURRENT_DESKTOP=GNOME /usr/bin/gnome-sound-applet"

to your startup list rather than just gnome-sound-applet, then you'll be able to right-click the icon and select 'Sound Preferences' to get at the more detailed controls, such as per-application volume controls. Otherwise it just takes you to the gnome control panel when you try to get at the sound preferences.

share|improve this answer
  1. Install the xfce-volumed package.

  2. Go to "Add New Item" menu of any panel,

  3. then add "Audio Mixer".

share|improve this answer

Also the volume control app may actually be apart of the Indicators plugin. Mine was and when I re-added the app it then brought my sound icon back.

share|improve this answer
For me the indicator plugin includes network, sound, and mail indicators. It's weird how they are all grouped together. This was super helpful, thanks! – Tom Sep 22 at 14:41

Followup to Chris Moore's answer: use env instead of needlessly invoking a heavy bash shell:

env XDG_CURRENT_DESKTOP=GNOME /usr/bin/gnome-sound-applet

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.