Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to ubuntu OS. I am trying to install skype on ubuntu 12.04. I am following a tutorial that says

sudo apt-add-repository “deb $(lsb_release -sc) partner”

but when i execute this command, it says:

lsb_release-sc: command not found 
share|improve this question
up vote 1 down vote accepted

You don't need to do this step manually. Use the Ubuntu Software Center and look for Skype.

You will have a button to use the partner source (Use Source). And then you can click to install Skype.

enter image description here

No command line is required.

share|improve this answer
Yes installed it from software update center. Thanks :) – baig772 Jun 4 '12 at 11:39

sudo apt-add-repository “deb $(lsb_release -sc) partner”

lsb_release-sc: command not found

I suspect that you simply forgot to put a whitespace between the command (lsb_release) and its options/switches (-sc).

share|improve this answer
:-) Please, take care to put ALL spaces. They are important. – Vitalie Ciubotaru Jun 4 '12 at 7:53
His command does not work (with spaces) on my PC, so I suspect other issues .. – david6 Jun 4 '12 at 9:01
now the command not found problem is finished but now it gives error: 'deb'; invalid :-( – baig772 Jun 4 '12 at 11:37

Some reason you're missing that executable. I have it on mine and according to dpkg -S, it is part of the lsb-release package.

ned@flanders:~$ dpkg -S `which lsb_release`
lsb-release: /usr/bin/lsb_release

What does your system say about that package?

ned@flanders:~$ apt-cache policy lsb-release    
  Installed: 4.0-0ubuntu20.3
  Candidate: 4.0-0ubuntu20.3
  Version table:
 *** 4.0-0ubuntu20.3 0
        500 precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0-0ubuntu20 0
        500 precise/main amd64 Packages

You can install with sudo apt-get install lsb-release provided your apt sources are correct.

share|improve this answer

Possible solution:

You are using the non-std apt-add- (should not matter), but are also using Windows-type unique characters for 'open-quote' and 'close quote'.

Try this instead:

sudo add-apt-repository "deb $(lsb_release -sc) partner"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.