Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to 12.04 from 11.10,Unity has started taking too long to start.

Booting from zero to BURG takes about 3 sec,BURG to login screen takes about 5-7sec...n then login screen to unity takes more than 2 min...why so?

I've even tried stuff like disableing networking and stuff...

share|improve this question
    
Pastebin dmesg output and current syslog –  izx Jun 4 '12 at 4:07
    
the dmesg output- paste.ubuntu.com/1025052 –  Nirmik Jun 5 '12 at 13:49
    
Better log to focus is /var/log/Xorg.0.log –  NikTh Oct 21 '12 at 14:37
    
How much ram do you have on your pc and what video driver U use ? –  Baltazar Blake Oct 22 '12 at 10:39
    
If you want to help to solve your problem : cat /var/log/Xorg.0.log >> xorg.txt then gedit xorg.txt and pastebin the output. –  NikTh Oct 22 '12 at 11:52

4 Answers 4

This sounds like https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1001138

Try moving aside the file ~/.config/compiz-1/compizconfig/config and then logging in again.

mv ~/.config/compiz-1/compizconfig/config ~/.config/compiz-1/compizconfig/config.backup

If you can login fast now, then you can put back the file and try to just delete these lines as described in the bug comments:

+[gnome_session]
+profile =

Or you can just leave it and use the freshly generated confg.

share|improve this answer
1  
nope!! no change whatsoever! still takes...AGES... :( –  Nirmik Oct 17 '12 at 11:09
    
In that case try creating a new user account and logging in under that. –  Alistair Buxton Oct 19 '12 at 12:40

Try to disable unused applications that start when you boot the system I did it and for me it worked . Disable some startup applications

By default on Ubuntu startup applications are no longer visible, for "security reasons" for new users, those processes that are started at boot time, some may be turned off if you do not need them, speeding up the boot, for make them appear open the terminal and type:

cd / etc / xdg / autostart /

And then:

sudo sed - in-place 's / nodisplay = true / nodisplay = false / g' *. desktop

Then insert our password. Applications now open boot and disable the services that you do not need

share|improve this answer
    
I don't think this is a problem with startup apps, it should not take so much time to finish starting up –  Anwar Shah Oct 23 '12 at 7:28

Install bootchart and pybootchartgui and upload the .png file in /var/log/bootchart.

Anyway, it'll show you the entire procedure from system up till the complete boot. Disable time-consuming but non-required packages. Install the application bug for this.

All these packages can be installed this way: $sudo apt-get install <package_name>

Also run the command:

    `$sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop`

Now open 'Startup Applications' and uncheck whatever you don't wish to load during boot.

share|improve this answer

I tried these tips and they worked for me. Really improved the performance of my machine.

Hope this will help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.