Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgrade my kernel

when I run update-grub, these are found

Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.4.0-3-generic
Found kernel: /boot/vmlinuz-3.2.0-24-generic-pae
Found kernel: /boot/vmlinuz-3.2.0-24-generic
Found kernel: /boot/vmlinuz-3.0.0-20-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

but when run uname -r, the kernel is 3.0.0-20.

How can I solve that?

share|improve this question
2  
You have tagged your question with grub2 but GRUB is updating menu.lst. Are you still using GRUB 1? What is the version number shown on your GRUB boot menu? screenshot –  irrational John Jun 4 '12 at 6:17
    
I retagged, it appears this may be an installation upgraded more than once, with the original install using grub1? Because grub2 is also installed (see line 6). –  izx Jun 4 '12 at 7:49

2 Answers 2

but when run uname -r, the kernel is 3.0.0-20. How can I solve that?

REBOOT!

When you upgrade the kernel, you must usually reboot to switch to the new kernel.

share|improve this answer

I had the same issue. What worked for me was to install GRUB2 because I was using grub 0.97. after you install grub2, update-grub and reboot the new kernel will be listed in the boot menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.