Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Gnome Shell working perfectly on my desktop, and I tried to install it on my laptop by the exact same method, (tried apt-get, synaptic and software centre), but it won't work. It seems to install fine with no errors. If I select "Gnome" at login, I get the "Gnome Classic" interface rather than Gnome Shell.

My laptop has sufficient specs to run Gnome Shell.

Am I missing something?

EDIT: I have just discovered that under System > Details > Graphics, it says "Unknown". So, Ubuntu hasn't recognised my graphics card, and I'm guessing this is why Gnome Shell can't work. I have a nVidia GeForce GT 525M. How can I get it working?

(as you may have realised, I'm a linux noob)

share|improve this question
    
What kind of graphics card do you have? Have you installed the proper drivers to use all of its functionality(flgrx for ATI, and nvidia-common for Nvidia) –  hexafraction Jun 3 '12 at 22:39
    
I have a nVidia GeForce GT 525M. I installed nvidia-common from synaptic, but it still says "Unknown" for Driver under Graphics in System Details. –  robawalsh Jun 3 '12 at 22:48
    
I wanted to mention that I believe the display in System > Details > Graphics is unreliable. It shows Unknown for my system with Intel graphics that are fully supported by the open-source drivers. I would recommend running lshw and seeing what driver it lists for your graphics card there. –  user68609 Jun 5 '12 at 18:39

5 Answers 5

You may try opening the Additional Drivers tool in order to install the Nvidia drivers. If they are not installed, or Additional Drivers fails, open a terminal(Also under System) and type sudo apt-get install nvidia-current and allow it to finish. It won't let you paste the command, so type it, and press Y whan it asks if you want to continue.

share|improve this answer
    
Nope, no luck. I ran nvidia-xconfig, and got: Using X configuration file: "/etc/X11/xorg.conf". VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf. Device section "Default Device" must have a Driver line. Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup' New X configuration file written to '/etc/X11/xorg.conf' I don't know if that helps. –  robawalsh Jun 3 '12 at 22:54
    
Now that you did that, try rebooting. Alas, I will be unavailable until about 8AM(Eastern/GMT-5) tomorrow, and 1:30 PM to help, but I'll respond then. –  hexafraction Jun 3 '12 at 22:56
    
After rebooting, I have got gnome shell working BUT, something is wrong with the graphics. I am stuck in a 640x800 resolution, and things load slower. So I think there's something wrong with drivers. After finding nVidia X installed, I tried installing Bumblebee, but to no avail. –  robawalsh Jun 3 '12 at 23:33
    
Can you paste /etc/X11/xorg.conf and /etc/X11/xorg.conf.backup on pastebin.ubuntu.com and give me the link to each(Separate pastes, please) –  hexafraction Jun 4 '12 at 11:36

I had the same problem with my XPS 15 with a GeForce GT 540M

My solution came up when I followed this tutorial.

Summing up, I just needed to upgrade my drivers with the new repository:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
share|improve this answer
    
-1 since while this solves it, it's a round-about brute force method that could potentially leave the user's system less stable. –  Bryce Dec 18 '12 at 20:33
    
I don't get it @Bryce , why do you consider it to leave the system unstable. Even the nvidia drivers are not that reliable and this solution has proven to be working for this far with me. Also, this repository is very well referenced. –  Fabricio Buzeto Dec 21 '12 at 17:00

http://www.filiwiese.com/installing-gnome-on-ubuntu-12-04-precise-pangolin/

I had some other gnomeshell performance issue when I was using ubuntu 12.04 beta version; I just had a new installation yesterday, following the instruction linked above, gnome shell works better now. Seriously, why ubuntu doesn't use gnomeshell as default, on my netbook, gnome shell is much more responsive and intuitive than unity ...

share|improve this answer

This is an NVidia driver issue however it is a little tricky to get it to function. I assure you it is there but there isn't any known fixes for this issue... yet. A workaround I had was to reboot PC then when it comes up hold the "Shift" key to get to the grub menu. Then choose "recovery" then after in the recovery you need to make sure the drivers are installed for the GC

      settings>additional drivers

Once that is done then log off (NOT SHUTDOWN) then choose the gnome from the menu and log back in. Once this is done then restart the computer.

share|improve this answer

According to https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-nv/+question/213879, you merely need to install mesa-utils.

I don't know why the gnome-shell package does not list this as a dependency. Will target bug #1091214 to address that point.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.