Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After Ubuntu boots, the tty1  Ctrl+Alt+F1 shows this:

Thegatorade-PC login: mountall: disconnected from Plymouth
mountall: Event failed

This happened after partitioning with gparted and happens every time I use Ubuntu.

share|improve this question
1  
Have you tried deleting the swap partition and re-creating it? –  Mitch Jun 3 '12 at 19:12
    
@Mitch no, will try. I resized the swap partition with gparted, probably that's why. –  TheGatorade Jun 3 '12 at 19:23
    
Let me know it it works? –  Mitch Jun 3 '12 at 19:28
    
@Mitch didn't try it yet. Will try. –  TheGatorade Jun 3 '12 at 20:40
    
@Mitch It worked. If you submit this as answer, I'll accept it. –  TheGatorade Jun 4 '12 at 16:01
add comment

5 Answers

up vote 4 down vote accepted

Try deleting the swap partition and re-creating it.

To do so Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo fdisk -l

to locate the device name for the partition you are going to format.

swap file must be turned off.

sudo swapoff -a

Remove swapfile:

sudo rm -rf /swapfile

To create

sudo mkswap /dev/sda5

Replace sda5 with you device name

sudo swapon -a

to tell Ubuntu to use the new swap partition.

Or you can use gparted. To install

sudo apt-get install gparted
share|improve this answer
1  
After I did mkswap it gave me a new UUID. I had to update the /etc/fstab with the new UUID to solve this problem. –  Apreche Aug 15 '12 at 14:33
add comment

First, confirm that gparted changed/updated the UUID of your swap partition. After the mountall: disconnected from Plymouth error appears, hit enter and you should get a logon prompt. Logon. From the command prompt, check the block ids of the partitions. sudo may or may not be needed:

sudo blkid

Take careful note of the UUID for the swap. Note that it will be exactly what's inside the double quotes, but that these quotes won't be used in the fstab file.

Next, check what UUID is listed for the swap in fstab:

sudo nano /etc/fstab

If it's different, carefully update the UUID to the new one that you wrote down. Ctrl+O to write out to file, after that press Enter so that the file will be saved to its current location, and Ctrl+X to exit. If there is anything extraneous in the fstab, you are likely to get a mountall: disconnected from Plymouth error..

By replacing the old UUID in fstab with the new one created by gparted, you can avoid having to delete the swap and recreate it from inside the OS, when you probably just did exactly that using GParted.

share|improve this answer
add comment

In my case I just needed to remove an unnecessary device in /etc/fstab.

share|improve this answer
3  
I thinks this is a good answer. But can you expand it with more details? –  Eliah Kagan Sep 29 '12 at 19:41
add comment

After cloning a physical hard drive (physical, 250GB) to another one (physical, 250GB), I GParted the cloned in order to clone it to another smaller SSD device (128GB).

Rebooting on the 250 GB GParted to 128GB (swap moved, etc). I got a mountall : Disconnected from Plymouth.

I don't understand how it could happen cause the system I cloned is a 10.04 Ubuntu server. (So I think there is no graphical so no Plymouth?)

Trying to re-create swap failed at step sudo swapon -a resulted to an error on my fstab, the swap label for sda5 was the one of the old hard drive.

Changing this label by the one on the line of sda1 remove the mountall error.

Hope it could help.

share|improve this answer
add comment

Mitch answer is not working for me. I can't re-create swarp, it says "device or resource busy". I tried this in both terminal and GParted(0.11.0-2 - the version in USC on 12.04) -- right click > format to > linux-swap, it shows the same error message.

I have fixed this issue by simply delete my swap partition completely with GParted, reboot my system. And then re-create a new partition again as linux-swap.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.