Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just downloaded the Humble Bundle with the game Bastion. After installing Bastion and starting it up, only it shows first a few logos, and then only a black screen and the mouse pointer. I can here the sound fine.

I read a message board that recommended starting it with -windowed -x 1280 -y 720 which does not work.

I am on Ubuntu 12.04 64 bit, with a Intel 3000 integrated graphics card. Does anyone know how I can get this to work properly?

share|improve this question
1  
I think it's just Linux driver flakiness. I had the same issue on open source Nvidia drivers until I installed the proprietary ones. –  Syzygy Jun 3 '12 at 17:27
    
Unfortunately, the reason the -windowed option doesn't work if you start with the shell script bastion64.sh (in /opt/bastion/Bastion as packaged trough the software center) is that the shell script doesn't pass the command line arguments on to the Bastion.bin.x86_64 binary. To fix this, append ' $@' to the 'LD_LIBRARY_PATH=lib64:. ./Bastion.bin.x86_64' line in the bastion64.sh script. Unfortunately, -windowed is the only way the game works for me. –  Steve Beattie Jun 11 '12 at 23:36

1 Answer 1

up vote 16 down vote accepted

This helped me:

sudo apt-get install libtxc-dxtn-s2tc0

Mike_IronFist said at ubuntuforums.org:

(Bastion) use S3tc textures and for some reason Intel graphics cards don't use these automatically on Linux.

Thread on the problem: http://ubuntuforums.org/showthread.php?p=11992661

share|improve this answer
    
This package fixed also "Psychonaut", that it wasn't starting before. –  dag729 Jun 11 '12 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.