Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello everyone and thank you in advance for your time. I have troubles with the latest Ubuntu distribution: since I upgraded to 12.04 Ubuntu has started having troubles (internal errors, packages that crash repeatedly, I can't install new packages, Ubuntu Software Center crashes, Java apps that worked stopped working and display weird mistakes, files were corrupted... a mess). I ultimately decided to format everything and install 12.04 from scratch. I made a backup and everything, but now I have troubles installing ubuntu 12.04. Specifically, a CD I burned with Brasero that works on another PC is not read by my laptop (not at boot phase, nor inside Ubuntu), and when I try to create a USB with Ubuntu (following the instructions I found on the ubuntu site) Startup Disk Creator stops at 22% saying that "the codes do not match".

Any idea on what to do next? No, I can't buy a new PC.

share|improve this question
"the codes do not match" is that the actual error message that pops up? – jippie Jun 3 '12 at 14:44
"I codici di conferma non corrispondono" is the actual error message that pops up. So, basically, yes. – user68080 Jun 3 '12 at 17:45
Can you start 'Startup Disk Creator' from the command line? I don't know what binary to call. But prefix the command with LANG=C. That way you get the proper error message. So on KDE it would be LANG=C usb-creator-kde but the command on Ubuntu will be slightly different. – jippie Jun 3 '12 at 17:54

If you can use an alternative CD , it can be loaded by the installer.

This link will walk you through.

Or choose PXE installation mode , that's harder to configure , and requires a second computer.


Some details about alternative CD , first , download the kernel and ramdisk from (this is for Precise):

Which is vmlinuz and initrd.gz (Replace i386 with amd64) if you're heading for x64 system

And use grub to load them (for windows use grub4dos)

kernel (hdX,X)/path/to/vmlinuz
initrd (hdX,X)/path/to/initrd.gz

When it boots , it will scan for your alternative CD from all partitions , if it was found , the installation will continue.

share|improve this answer
Uhm... The options I see following that link are (correct me if I'm wrong): 1. Installing from USB (failed) 2. Correcting the boot of the system in order to run CD (useless) 3. Installing within Windows (I have Ubuntu) 4. Floppies (not on my laptop) 5. Install from existing Linux Number 5 could work, but it fails on step 2, 'cause it says the directory tmp/install_cd is on read-only mode... – user68080 Jun 3 '12 at 17:37

here is a quick tutorial on how to install Ubuntu from floppies

share|improve this answer

Try UNetbootin

The error you're getting from Startup Disk Creator seems like it is notifying you of an inconsistency between what it tried to write and what got written. Try writing the USB flash drive with UNetbootin.

Try dd

If that fails, try writing it with dd. If you're not experienced with dd, these instructions should help:

  1. Attach the USB flash drive to your computer. If it's already attached, detach it and plug it back in.

  2. Open a Terminal window. One way to do this is to press Ctrl+Alt+T.

  3. Run this command:

    dmesg | tail -15

    You'll get output that looks something like this:

    [596945.217631] usb 6-1.3: not running at top speed; connect to a high speed hub
    [596945.268065] scsi8 : usb-storage 6-1.3:1.0
    [596946.284682] scsi 8:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
    [596946.287536] sd 8:0:0:0: Attached scsi generic sg4 type 0
    [596946.293669] sd 8:0:0:0: [sdd] 3973120 512-byte logical blocks: (2.03 GB/1.89 GiB)
    [596946.296661] sd 8:0:0:0: [sdd] Write Protect is off
    [596946.296667] sd 8:0:0:0: [sdd] Mode Sense: 23 00 00 00
    [596946.299803] sd 8:0:0:0: [sdd] No Caching mode page present
    [596946.299808] sd 8:0:0:0: [sdd] Assuming drive cache: write through
    [596946.320081] sd 8:0:0:0: [sdd] No Caching mode page present
    [596946.320088] sd 8:0:0:0: [sdd] Assuming drive cache: write through
    [596946.404683]  sdd: sdd1
    [596946.417670] sd 8:0:0:0: [sdd] No Caching mode page present
    [596946.417675] sd 8:0:0:0: [sdd] Assuming drive cache: write through
    [596946.417679] sd 8:0:0:0: [sdd] Attached SCSI removable disk

    The letters in the [ and ] brackets identify the device. The full device name is that, with /dev/ prepended to it.

  4. The device (in my example, /dev/sdd) probably has a single partition, and that partition was probably mounted automatically when you plugged the device in. Unmount that partition:

    sudo umount /dev/sdd1

    Make sure you replaced /dev/sdd with the right device name for your device.

    sudo runs commands as root. You may be prompted for your password in the Terminal. As you enter it, you won't see any placeholder characters (like *). That's OK. Just type it in and press Enter.

  5. Change directory to wherever you have your Ubuntu .iso. For example, if it's located in the Downloads folder in your home folder, you'd run this command:

    cd ~/Downloads

    The ~ character, used this way, stands for your home folder (/home/username)

  6. Use the dd command (running it as root, with sudo) to write the .iso image to the flash drive:

    sudo dd if=ubuntu-12.04-desktop-i386.iso of=/dev/sdd

    Make sure to replace ubuntu-12.04-desktop-i386.iso with the name of the .iso image you want to write (if different), and make sure to replace /dev/sdd with the device name of the drive you want to write it to. Please note that it is not correct to have a partition number in this device name (so it will look like /dev/sdd, not /dev/sdd1 as when you unmounted the volume).

    Writing the .iso image to the USB flash drive may take a while, and it typically won't show you any output in the Terminal while it's working, but when it's done, your USB flash drive should be bootable and suited for trying or installing Ubuntu.

A reasonable alternative to steps 5 and 6 would be to type sudo dd if= into the Terminal, drag the icon for the .iso file from Nautilus (the file browser) into the Terminal (this will paste its full path), press Space, and then add of=/dev/sdd (or whatever the proper device name is).

Finally, please remember that if you give of= the wrong device name, you can overwrite all or part of a drive that contains your valuable data. So be very careful about this.

share|improve this answer

My experience with dd is that it only dumps the data to the flash drive. It does not help to make it bootable at all. I tried it with a flash drive I know is bootable and it would not boot from it. UNetbootin worked though--both the Windows and Ubuntu versions.

share|improve this answer
Whether or not an .iso image can be written directly (for example, with dd) to a USB flash drive to produce a bootable flash drive depends on the .iso image itself. .iso images that contain the necessary structure and files to be bootable both when burned directly to CD/DVD and when written directly to a USB flash drive are said to be hybrid images. Ubuntu has used hybrid .iso images for its desktop CD starting with version 11.10. – Eliah Kagan Jun 25 '12 at 10:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.