Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have an old nvidia card not supported anymore (Ti4200Go agp 8x). The nouveau driver has problems drawing the cursor and shows ugly pictures on the screen. How do I try the vesa driver? I'm sad the vesa won't display the full 1680x1050 native resolution, but at least the laptop will be usable.

share|improve this question

2 Answers 2

Try blacklisting the nouveau driver by adding the line blacklist nouveau to the file /etc/modprobe.d/blacklist.conf(you will need root privilege). This will prevent that driver from loading. Also comment any line like blacklist vesafb by replacing it with #blacklist vesafb in the file /etc/modprobe.d/blacklist-framebuffer.conf

share|improve this answer

I have the same exact video card on a notebook that can't use a newer video card because it uses the AGP bus rather than PCIE or something newer. This was the solution that allowed me to use the nvidia96 driver with Lubuntu 12.04 by keeping the xorg from 11.10: See post #24 by zecoyote007

In order to use nvidia-173 or nvidia-96, please see my post here:

I found a workaround: keep the 11.10 version of the Xorg server No conflict at all with any package from 12.04 !!!

nvidia-173 drivers are not compatible with Xorg (ABI to be precise) version released in 12.04. So I stick with 11.10 version of Xorg. I had to make the following changes to backport Xorg:

1) In /etc/apt/sources.list :

deb oneiric main deb-src oneiric main

2) In /etc/apt/preferences:

Package: xorg xserver-xorg* Pin: release a=oneiric Pin-Priority: 1050

3) Note related to nvidia-173/96 on Ubuntu 12.04 (optional if you face slow graphics) I'm using old hardware with nvidia-173 drivers and I don't like the fact "composite" is mandatory to use Unity correctly (very laggy) I had to force composite to switch it "off" to avoid laggy windows by modifying /etc/X11/xorg.conf:

Section "Extensions" Option "Composite" "Disable" EndSection

This works for me, at least until (fingers crossed) nVidia updates the nvidia96 driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.