Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since the upgrade from 11.10 to 12.04 the battery icon / power indicator is not shown any more in the menu bar.

I went to 'system settings'-->'power' and tried to set 'show battery status in menu bar' to 'always', however the selection button seems to be corrupt. Strangely, when I open the power settings dialog, the 'show battery status in menu bar' field is set to an empty string instead of showing one of the three possible choices. When I click on the small arrow next to it, the three possible choices are shown. Whatever I select, upon closing the settings dialog and reopening it, the selection field is back to empty.

share|improve this question
Unity, gnome-shell or both? – jasmines Jun 4 '12 at 7:22
Still not working here. Please, any suggestions? – user488728 Jun 24 '12 at 6:37

Open the Terminal (Ctrl+Alt+T) and run this command, which tells you what kernel version you are running:

sudo uname -r

If you don't have the updated 3.4 kernel image then go download the files according to your system from

Make sure the downloads are in your Downloads folder, and make sure that those are the only .deb files you have in your downloads folder. Then run these commands in the Terminal:

cd ~/Downloads
sudo dpkg -i linux*.deb

Press Enter. If you're prompted for your password, type it in and press Enter. (You won't see anything on the screen as you type in in--that's fine.)

Let the kernel install, reboot the computer and you should be good to go.

share|improve this answer
Are there any disadvantages or dangers of using the 3.4 mainline kernel that users should know about? – Eliah Kagan Jun 5 '12 at 18:59
Upgraded to the kernel 3.4, however this did not solve the problem. – user488728 Jun 8 '12 at 7:09
My Virtualbox is broken now. Seems to be due to missing kernel modules. Cannot get it to work even after following this… instructions (which worked for me previously). So, uninstalling the 3.4 kernel. – user488728 Jun 10 '12 at 12:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.