Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I work on my laptop and ssh into my desktop. I use a lot of key based authentication for many servers for work but recently I couldn't login because ssh would pick up and try all the keys and it stops trying before ultimately falling back to password based login. So right now I am using this command: ssh -X -o PubkeyAuthentication=no [email protected] #deskto

The issue is after sometime the desktop would just become unreachable from laptop. I won't be able to open its localhost through IP and today I tried ping'in it and found a weird thing. Instead of 192.168.1.4, it tries to ping 192.168.1.3 which I am sure is the root cause as it just can't reach 192.168.1.4 when its actually trying for 192.168.1.3

Ping command output:

ashfame@ashfame-xps:~$ ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4) 56(84) bytes of data.
From 192.168.1.3 icmp_seq=1 Destination Host Unreachable
From 192.168.1.3 icmp_seq=2 Destination Host Unreachable
From 192.168.1.3 icmp_seq=3 Destination Host Unreachable
From 192.168.1.3 icmp_seq=4 Destination Host Unreachable
From 192.168.1.3 icmp_seq=5 Destination Host Unreachable
From 192.168.1.3 icmp_seq=6 Destination Host Unreachable
From 192.168.1.3 icmp_seq=7 Destination Host Unreachable
From 192.168.1.3 icmp_seq=8 Destination Host Unreachable
From 192.168.1.3 icmp_seq=9 Destination Host Unreachable
^C
--- 192.168.1.4 ping statistics ---
10 packets transmitted, 0 received, +9 errors, 100% packet loss, time 9047ms
pipe 3

Also the ping command message comes in multiple and not one by one. (izx answer's the weirdness I thought there was in ping command.)

I did check for desktop, its local IP is still the same, so something is going on in my laptop. Any ideas?

P.S. - Laptop runs Ubuntu 12.04 & Desktop runs Ubuntu 11.10

Laptop is connected through wifi to router and Desktop is connected through LAN to router.

Update: Even after setting up static IP leases in router settings, I again ran into this issue.

share|improve this question
    
Your wifi may be broken... –  izx Jun 3 '12 at 13:55
    
@izx broken as in? It used to work fine before. I have been doing this for months, I guess an upgrade messed it up. Also having another issue related to audio hardware on the desktop. –  Ashfame Jun 3 '12 at 14:01

2 Answers 2

PING 192.168.1.4 (192.168.1.4) 56(84) bytes of data.
From 192.168.1.3 icmp_seq=1 Destination Host Unreachable

ping is not somehow mysteriously reaching .3 in its quest for .4 -- you must go through .3 to get to .4, and this is .3 telling you it can't reach .4 to complete the connection.

This message usually comes from a gateway or even your localhost. The latter is more likely since gateways are usually .1s. What is your laptop's IP? Does it otherwise have internet connectivity? If so, this may be a problem with your router rather than with the computers.

share|improve this answer
    
Hmm that makes sense. It was .3 I just assigned static IP lease on LAN to see if that helps. –  Ashfame Jun 3 '12 at 7:52

Same for me. Someone here says that could be just a matter of moving the access point.

share|improve this answer
    
For me the computer which becomes unreachable is connected via a LAN cable. –  Ashfame Jun 20 '12 at 7:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.