Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since Ubuntu 12.04, My Insignia TV says no signal on VGA after booting. I switched to HDMI and all is well but there is no audio output. After logging in to my account, I can switch back to VGA and then all is fine. How do I change the startup resolution so it can display on VGA?

share|improve this question
1  
Do you have both connected at boot? –  Mitch Jun 3 '12 at 7:09
    
Are you using nvidia driver? –  Ravi Jun 3 '12 at 7:52
add comment

3 Answers

I figured something out, and just hoped it would help someone else. I tried everything. On the main screen with all the log-in names, there are no display options, yet it is too high to work right. Once logged in, of course you have resolution options. I had nothing to lose, so I reinstalled Ubuntu (which I LOVE by the way). On the set up screen where it asks if you want to try or install, the top right-hand option is 'settings' but after you install changes to a power button. If you change the resolution BEFORE installing, it will keep the setting for the log-in screen. After the install, it apparently sets itself. Now everything works fine on VGA. Thanks for the ideas. I hope this helps someone else.

share|improve this answer
add comment

Sorry, I forgot to mention that my graphics card is the XFX ONE (ON-XFX1-PSR).

I do have both connected at boot now, only because if I only have VGA plugged in, I can view the initial boot screen of my computer starting up, but when it gets to the login screen, I get ''mode not supported'' on my TV. I think the resolution must be too high on the login screen (where it shows all the users) because once I switch to HDMI, all the letters are small. Once I log in on HDMI, it goes to ''mode not supported'' on my TV and when I switch to VGA everything is fine from there on out.

I tried solution 1 above but it made no difference. I'm scared to try number 2, because I'm unclear exactly how to add that to the end (space?).

I also can go to settings>hardware>additional drivers, and it finds 2 ATI/AMD proprietary drivers, but the first is the ''post release updates''. When I install the initial one and reboot it makes no change. When I try to install the updates, it fails and deactivates the first one. It also makes videos smaller when I go to full screen in Youtube. Thanks for the help.

share|improve this answer
    
I know why the 1st doesn't works (it doesn't affects Ubuntu) –  espectalll123 Jun 5 '12 at 20:52
    
If you want to do the second... –  espectalll123 Jun 5 '12 at 20:53
    
A screen with some options appears before booting Ubuntu? –  espectalll123 Jun 5 '12 at 20:54
    
And... What? Smaller videos in YouTube? :/ –  espectalll123 Jun 5 '12 at 21:10
add comment

NOTE: if you do this wrong, you will lose your computer! (at least, before repairing the boot)

  1. Open a terminal from the dash.
  2. Paste this: sudo gedit /boot/grub/menu.lst
  3. Search a line which shows something like this: kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda5 ro quiet splash
  4. At the end of the line, add, for example, vga=791 (more info at Wikipedia and at Ubuntu Forums)
  5. Save the file.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.