Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran through the troubleshooting at https://help.ubuntu.com/community/SoundTroubleshooting

It did not play the test sound, and it also does not play sounds during speaker-test. It does play sounds when I adjust my volume on my computer (using pommed). It worked just the other day, but this is the first time I've tested it since last night, when I put it to pm-suspend-hybrid and it half-woke up (the backlight came on, but it didn't fully wake up), then went back, then half-woke again, but was frozen like that. I had to do a manual reboot of the machine when that happened. Now my sound doesn't work, except for adjusting the volume (where the little "beep" sound plays).

During the troubleshooting, it recognized my sound card, the sound modules, and the sound card's installation. I've tried removing ~/.pulse, but to no avail.

Also, if it's any help, pulseaudio is running, but pulseaudio --check returns nothing, which the manpage suggests indicates an error.

Edit: I should probably clarify that the wake up from the suspend-hybrid was not provoked in any way. I was laying in bed when I noticed my room was brighter suddenly, so I got up to check on it.

share|improve this question
    
Another report from the field: I just tested padsp, which is supposed to be used in the case of an error "Cannot open /dev/dsp", and, while it was working previously, it no longer works and reports the same error that it was supposed to fix. sudo apt-get -f install does not report anything. –  Brian West Jun 3 '12 at 7:09
add comment

2 Answers

I seemed to have managed to fix it. I don't quite understand what I did, because I cleared the cache before, but I guess when I tried to stop it beforehand, it didn't listen to me. In any case, maybe it's my imagination, but it feels like audio quality is slightly worse after doing this:

This is adapted from http://ptspts.blogspot.com/2010/11/how-to-disable-pulseaudio-on-ubuntu.html

$ pkill -STOP '^pulseaudio$'
$ rm -rf ~/.pulse

$ mkdir -p ~/.pulse
$ echo 'autospawn = no' >~/.pulse/client.conf

$ pkill -KILL '^pulseaudio$'

And then I just opened spotify and things seemed to work again. Hopefully this isn't just temporary.

share|improve this answer
add comment

Check the output of alsamixer. If any channel is muted it will be marked as MM, then navigate to that channel using arrow keys and press M to unmute and use up-key to increase volume.

share|improve this answer
    
I did that with the gnome-alsamixer, but nothing was muted, and everything is at max volume. I've had trouble with that in the past, because if I use my mute key, it doesn't like to unmute again later, but in this case, that doesn't appear to be the problem. –  Brian West Jun 3 '12 at 12:47
    
I guess you have tried alsa force-reload or alsa resume. What was the output? –  Samik Jun 3 '12 at 15:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.