Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using Ubuntu for a while now and I love it, I wouldn't think of using another OS unless I can't fix this issue.

The install I'm on is only around a month and a half old. I'm running 12.04 64bit on a 8,1 MBP.

Up until around 2 weeks ago everything was running smoothly. Around then applications started crashing and weird things started happening. At first I thought it was just certain applications.

The first thing to start giving me trouble was compiz. Occasionally compiz will stop decorating windows and lost many other functionalities. running compiz --replace fixes this, but I don't feel like doing it usually once a day. The other thing with this is that after running compiz --replace, my conky window gets lost somewhere and so I run killall conky && conky -c .conkyrc.

But this isn't with just a couple applications, it seems like it is proliferating through my system.

Last week fontforge started crashing while doing whatever task. So I ended up unable to finish what I was working on to completeness. Didn't find a fix.

Today rhythmbox started crashing. Whenever I try to play anything, Rhythmbox becomes unresponsive and needs to be forced to close.

When I try to do certain things with the disk utility, it crashes.

I get the Ubuntu has experienced an internal error message much more often than I would like. Frequently applications stop appearing in the launcher. Wine almost never does anymore.

After not being active for a little while, thunderbird can only fetch my mail after restarting wireless, sudo rmmod b43 && sudo modprobe b43

Occasionally some of my startup apps don't start.

What is my best option here? Could they be bugs? I don't want to submit a ton of vague bug reports. Reinstall? switch OS?

Thank you to anyone who responds. Kopkins

share|improve this question
    
1st of all, why don't you use 32 bit.it is recommended by Ubunut.com. check this link to know why it is recommended: askubuntu.com/questions/55226/…;. try the LiveCD 32 bit and install some apps and see if it still crashes. as for conky I have the same thing but before giving the solution I want to make sure that this is the same problem. Did you put conky in the startup application box? –  Suhaib Oct 18 '12 at 3:32
    
If you run rhythmbox through the terminal by pressing ctrl+alt+t and then typing rhythmbox and pressing enter, what output do you get? Also look in log viewer to see if there's any odd messages. –  handuel Apr 7 '13 at 12:13

1 Answer 1

This is pretty unusual, and you are most likely correct that the problems are all related, and are not caused by any of the individual symptoms. From what you've described, I'd certainly be looking at a hardware problem, such as a bad memory chip.

I would start with the Memtest86 bootable program, and let it run all the tests for a while. You should have a copy at the Grub startup menu, I think.

If that doesn't show any problems, you should look at your Hard Disk drive. Make sure SMART is enabled, then take a look at the statistics in the disk utility, under SMART Data.

There may be something in the logfiles that can give a clue if all else fails.

share|improve this answer
    
Thanks for the reply. Definitely seems like a possibility. Unfortunately, running memtest86 yields an error, error: too small lower memory (0x99100 > 0x8f000) I also can't refresh the SMART Data, Disk Utility crashes as soon as I try anything. Could I run it from a live cd? –  Kopkins Jun 3 '12 at 3:45
    
Seems like the Memtest error may be a bug in the program. May be only larger amounts of ram; if so, maybe you can check a subset, or try cycling out part of the memory to see if it ever works with one missing. There may be a disk utility for your HDD that will check the disks. A lot od HDDs come with utilities, and may have downloads on the website. –  Marty Fried Jun 3 '12 at 4:16
    
I could boot to my Mac partition and use its disk utility, right? I'll try cycling the memory. –  Kopkins Jun 3 '12 at 15:22
    
Might try a different version of memtest… –  keepitsimpleengineer Jun 3 '12 at 17:44
    
Memory is memory. If it works, give the memory a workout. As for a different version, I did a quick search, and at least one person with this problem went pretty far back in versions with no success. –  Marty Fried Jun 3 '12 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.