Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm currently using a virtual machine to run ubuntu server. I installed maas on it. I got this error everytime.

The requested URL /MAAS was not found on this server.
Apache/2.2.22 (Ubuntu) Server at Port 80

I tried to access the web interface. I don't understand what I'm doing wrong. Can someone help me out? Thank you.

share|improve this question
This is unusual. It may mean that installation failed somehow, or that the setup conflicts with something else that you have running, such as another web application. See if you can find something relevant in the logs: /var/log/maas/* and /var/log/apache2/error.log (and perhaps if your requests are coming through in /var/log/apache2/access.log). Also, do you have a file /etc/apache2/conf.d/maas-http.conf installed? If that were missing somehow then you might get this kind of failure. – user72439 Jun 22 '12 at 4:59

3 Answers 3

Just change ur url from this




this might be funny but it actually worked trust me

try the url without the quotes "

share|improve this answer

Looks like something went wrong when you installed the package. Please make sure that the package is installed by checking if the file /usr/share/maas/maas/ is present on your system. Then you need to make sure that the apache configuration is properly installed by making sure that /etc/apache2/conf.d/maas-http.conf is a valid link.

As a last resort option, you can purge the package and reinstall it:

sudo apt-get purge maas
sudo apt-get install maas
share|improve this answer

I do no if this is the right answer to your question but I faced the same kind of problem : The MaaS web user interface became unrecheable after changing the IP address of my controller.

The solution was to reconfigure a lot of MaaS related packages :

dpkg --get-selections | grep maas

Here is the output :

maas                    install
maas-cli                install
maas-cluster-controller install
maas-common             install
maas-region-controller  install

I reconfigured the packages :

$ sudo dpkg-reconfigure maas-region-controller
$ sudo dpkg-reconfigure maas-cluster-controller
$ sudo reboot

... All works fine now !

Hope it helps.

share|improve this answer

protected by Community Oct 31 at 11:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.