Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've been attempting to set up my new brother multi-function device to work as a printer and scanner using the following steps. It is connected to the network as a LAN device, not directly connected to my ubuntu machine.

  1. Search Brother support for the MFC-J825DW and download the deb packages for the lpr driver and cupswrapper drivers.
  2. Follow install instructions for each driver, making sure you have all required packages installed (ia32-libs or lib32stdc++ if using 64bit ubuntu for example).

After this point I was able to successfully perform a test print, so the printer part is working. So far I haven't had much luck getting the scanner working. This is what I've tried:

  1. Download the brscan4 and scan-key-tool deb packages from brother support as above.
  2. Followed the instructions for installing these ensure you have all requried packages installed (such as sane-utils).

However when I tried to scan it detects no scanner.

I then tried the solution offered in this answer to a question based on a similar brother printer, but no luck. I must have made a mistake somewhere along the line. Does anyone have any ideas what I can try to find out what? Or should I uninstall everything and start again from the beginning?

share|improve this question
Did you copy the libs: – Takkat Jun 2 '12 at 21:32
@Takkat I shouldn't need to do that as I'm not on a 64bit machine as far as I'm aware. – AntonChanning Jun 2 '12 at 21:44
@Takkat Thanks for that hint, made my MFC-465CN get recognized as a scanner! Should be the answer to the problem. – rearlight Jul 1 '13 at 16:32
@rearlight: well, it already is an answer on the site - glad it helped. – Takkat Jul 1 '13 at 18:36

2 Answers 2

up vote 5 down vote accepted

I think this is a case of only being stuck until you ask for help. Soon after posting this I decided to check the ip addesses of the printer and scanner. Sure enough I'd entered a different ip for each one somehow. Since the printer worked and the scanner didn't, I made the assumption that the scanner had the wrong one.

To correct this I had to enter the following line at the command prompt:

brsaneconfig4 -r SCANNER

This command removed the scanner with the incorrect ip address. Then I simply added it back again, making sure the ip address was right this time.

brsaneconfig4 -a name=SCANNER model=MFC-J825DW ip=

Note: You should probably set the scanner up to a fixed ip in the router, otherwise you may have problems later on when it gets assigned a different ip when the router is reset.

share|improve this answer

I was not able to add a comment, but I wanted to confirm that @AntonChanning's solution worked for the MFC-J870DW also.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.