Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

just did upgrade from kubuntu 10.04 to 10.10.. after all done and reboot, when the login box shows up, my keyboard and laptop pad ( mouse ) dosn't work, (plugged in the usb mouse, it works sometimes) but never keyboard. i went to recovery , the boot hung up when it says :

[    17.704053] EXT4-fs (sda9): mounted filesystem with ordered data mode
Begin: Running /scripts/local-bottom ...
Done.
Done.
Begin: Running /scripts/init-bottom ...
Done.

stuck here. nothing works except ctrl+alt+del

i tried booting from livecd and update-grub, also tried booting manually from grub command line, everytime it stuck at lines above .. so it's not grub problem . how to solve this ?

if it is important, i have ATI mobility radeon HD 5470 card .

share|improve this question
    
Hello, I also encountered that problem, and now I haven't resolved it. I also want to get help from who have experience. I don't know whether you resolved it. –  hegerer Jan 14 '11 at 17:50
    
@hegerer This question has been marked as answered and solved. Please see the below accepted answer. –  Marco Ceppi Jan 14 '11 at 17:51

1 Answer 1

up vote 2 down vote accepted

I would say you have a few options...

  1. Boot up with the livecd, open a terminal, make sure your old install gets mounted, do a chroot to your existing install, try checking out apt, try reinstalling the kernel (apt-get install package-name --reinstall will reinstall a package), also some other core packages, see if that works, if not do more digging until you either fix it or give up.

  2. Boot up with livecd, mount the old install, back up your data to an external device, and reinstall.

Depending upon what broke and if you're a ninja, 1 might be quicker, otherwise, go with 2. I have also had some upgrade pains to 10.10, had to reinstall ubuntu-desktop and a few other packages.

Hope that helps

share|improve this answer
    
thansk, i'd try option 1, btw while digging on the net, i'v found someone stuck at the same line and fixed it by repairing missing /sbin/initctl.. will try these with your option1 and will back . –  avar Nov 23 '10 at 17:53
    
hello again. i booted from livecd, and mounted my HD, chrooted and reinstalled upstart . reboot and my system is running .. except recovery mode still stuck there. thanks. –  avar Nov 24 '10 at 17:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.