Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 on my VAIO SB36 and it overheats and the fan speed is at max. How should I fix it?

System Specs:

Intel® Core™ i5-2430M CPU

Unknown graphic detects! (it's both intel and ATI 6470M)

Thanks in advance!

share|improve this question
add comment

2 Answers

I really do not think it an OS problem, and I do not think its normal either. A friend of mine has the same laptop, with Windows 7, and has the same problem.

It is known that the Vaio SB suffers from heat and noise problems. As powerful hardware and thin profile don’t go hand in hand. The fans will be particularly noticeable when using the dedicated video card. But if gets way too hot, I would call Sony, to see what they say about it.

share|improve this answer
    
I don't think so!in win 7 it's cool and doesn't have this problem. –  Davood.M Jun 2 '12 at 17:00
    
The guy is setting next to me, and his machine is very hot to the touch, and it sounds like it about to take off.. –  Mitch Jun 2 '12 at 18:47
    
that's his problem!!Now I have Mint 13 and don't have any problems...Even in win 7 with 4 open VS 2010 and Gtalk, chrome .... still cool :P –  Davood.M Jun 3 '12 at 4:37
    
I`m glad the your is OK :) –  Mitch Jun 3 '12 at 5:11
add comment

Usually, the overheating problem in Ubuntu is related to the graphic card, and in your case, you have an Hybrid graphic card with the open source drivers. In this case, by default, you have both graphic cards connected but you are only using the integrated (Intel). If you want to use only one and when you want, you need to install the privative drivers following this answer:

What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

And using the latest driver:

(6 jun) http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13-4-linux-x86.x86_64.zip

share|improve this answer
    
This worked to me because I have a HP Pavilion dv6 6c13ss with ATI Radeon HD 7690M XT and Intel HD Graphics 3000 and the latest driver fixed the overheating problem when I enable the powersave graphic card (the integrated one, Intel). –  Leo Jun 6 '13 at 22:32
add comment

protected by Community Oct 26 '13 at 9:39

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.