Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to update my Ubuntu system, but cannot do anything with the Update Manager. It loads up 3/4 of the way and then says:

Could not initialize the package information
An unresolvable problem occurred while initializing the package information.
Please report this bug against the 'update-manager' package and include the following error message:
'E:The package google-chrome-stable:i386 needs to be reinstalled, but I can't find an archive for it.'

Also ubuntu software center will not open and keeps crashing. This is very annoying as I can't install or update anything.

share|improve this question
Are you running the 32-bit or 64-bit version of Ubuntu? If you're not sure, please open a Terminal window with Ctrl+Alt+T and run uname -m, then provide the output. – Eliah Kagan Jun 2 '12 at 18:01
hi Eliah i am running a 32 bit version of ubuntu – Howie Lynch Jun 11 '12 at 13:39

It looks like this is happening because the third-party software source for Google Chrome was disabled when you upgrade from one Ubuntu release to another. Then the solution to this problem is to re-enable the software source, making sure it is configured for the Ubuntu release you are currently running, and then update again.

To do this, open the Update Manager. Click Settings... on the lower-left corner of the Update Manager window, to bring up the Software Sources window. Click the Other Software tab. Find the entries for Google Chrome (there will probably be two of them). They might say disabled on upgrade to _____ with _____ replaced by the codename of some Ubuntu release (e.g., precise). But they will not necessarily say that.

For each one, click on it and click Edit....

If the Distribution text box contains stable, leave it that way. This is how the Google Chrome software source currently works.

If you are doing this for a future versions of Chrome which might work differently, or for some other software, make sure the Distribution text box contains the codename (in all lower-case letters) of the Ubuntu release that you are currently running.

If you're not sure what that is, open a Terminal window (Ctrl+Alt+T) and run the command lsb_release -c. That will tell you.

Thanks to Samik for pointing out that the current version of Google Chrome's software source does not use an Ubuntu release codename, but instead uses the general stable codename from Debian.

If the Comment text box contains just disabled on upgrade to _____, then you can go ahead and delete that text too.

Then click OK. Make sure to do this for both Google Chrome software source entries.

Enable these software sources by clicking the empty checkbox next to them.

Then click Close to quit out of the Software Sources window. You should now be able to update successfully.

(If this doesn't work, please leave a comment to facilitate further troubleshooting.)

share|improve this answer
This approach is really helpful, just want to add up an alternate way, check the existence of the file /etc/apt/sources.list.d/google-chrome.list. If it is not there create one and add deb stable main to it. – Samik Jun 2 '12 at 16:03
@Samik Actually, I'm very glad you posted that, since it reminded me of how Google unfortunately doesn't follow standard conventions for Ubuntu software sources. This software source must be configured a (generic) Debian series name. I'll edit the answer to fix this. Meanwhile, you may want to post your comment as a separate answer, if you're willing to explain, in a way suitable for people not familiar with the command-line and running programs as root, how to do this. – Eliah Kagan Jun 2 '12 at 16:10
Particularly for this reason it seems a bit odd that Ubuntu has disabled this repository on upgrade as it is not associated to specific Ubuntu version. – Samik Jun 2 '12 at 16:33
@Samik I don't think that's odd. When you upgrade an Ubuntu system, the default behavior is to disable any non-official software sources. I think it would be odder if update-manager-core considered a repository with a non-standard (for Ubuntu) release name official. – Eliah Kagan Jun 2 '12 at 16:39
Eliah / Samik , i've tried opening update manager to get to settings but it will not open without the error coming up on screen therefore io cannot get into the update manager settings in the bottom left . I cannot update or install anything at the moment . – Howie Lynch Jun 11 '12 at 13:45

Follow these steps:

  1. open gnome-terminal by pressing Ctrl+Alt+T
  2. write echo "deb stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list to write the line to the file as root, if that file doesn't exist it'll be created.
  3. then perform an update by writing sudo apt-get update and provide any error reported.
share|improve this answer
hi samik that worked thanks a million !!!! – Howie Lynch Jun 11 '12 at 13:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.