Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Linux, and it seems my brightness settings will not change. I have keys on my laptop for it, and they lower and raise the brightness bar but the screen does not change brightness. Help?

Some specs: My laptop is a HP dv7t-6100 CTO. I have Linux Ubuntu 12.04 lts dualbooted with Windows 7. I can provide more if you need to know.

share|improve this question
1  
What Laptop, what Distribution... –  Bobby Jun 2 '12 at 15:27

1 Answer 1

Do you have acpi enabled? If so, do you have a /sys/class/backlight/ directory populated by folders named acpi_videoX, where X is some integer (normally 0 or 1)? If you do, check whether the brightness and/or actual_brightness files within those folders have their contents changed when you attempt to alter the brightness level. You might also consider installing the xbacklight package and checking whether it works to change your brightness settings.

share|improve this answer
    
So, I didn't have acpi installed, but I installed it. I noticed no difference. I checked the folders (In that directory I have acpi_video0, acpi_video1, and intel_backlight), and each of the acpi_videoX folders have brightness and actual_brightness. They do change. At max brightness, each of the files say 10. After one press of the dim key, each of them go to 6 except the acpi_video0/brightness. It went to 8. I installed xbacklight and it didn't help either. –  Wallace Panter Jun 3 '12 at 4:37
    
First, make sure acpid is actually running (ps aux | grep acpid). Then, try manually editing each of the individual brightness files in each of the sub-folders in the /sys/class/backlight/ directory by altering the value to some different integer (less than the one specified in max_brightness). As soon as you save, the screen should dim appropriately if the file is indeed operative. If that doesn't yield any results, I'm afraid I'm out of ideas. Sorry. –  Greg E. Jun 3 '12 at 4:56
    
You could also try the solution to a similar problem described here, if you haven't already. –  Greg E. Jun 3 '12 at 5:02
    
Thanks, Greg. The link in that last post worked for me. –  Wallace Panter Jun 3 '12 at 16:32
    
No problem, all credit to the original poster of that solution. :) –  Greg E. Jun 3 '12 at 16:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.