Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run Amnesia: Dark Descent or Superbrothers: Sword & Sworcery, the games are stretched across both my monitors, like this:

enter image description here

Limbo crashes on start-up:

enter image description here

How can I solve these problems?

share|improve this question
3  
I yanked the cable of my second monitor. –  Captain Giraffe Jun 2 '12 at 15:24
    
Thank you so much for asking this. I thought I was the only one experiencing the problem. –  Thomas Boxley Jun 10 '12 at 0:38

2 Answers 2

up vote 16 down vote accepted

All Games work after some tweaking:

Amnesia, Sword & Sworcery, Psychonauts, Super Meat Boy:

These are SDL games, and like all SDL games, they will act strangely if you have two monitors. To run them on only the primary display:

SDL_VIDEO_FULLSCREEN_DISPLAY=0 /opt/amnesia/Launcher.bin64 - note this will probably be called "Launcher.bin32" or similar on 32-bit systems.

SDL_VIDEO_FULLSCREEN_DISPLAY=0 /opt/swordandsworcery/run.sh

I didn't need to do any further tweaking with these and they seem to work perfectly.

NOTE: To apply this tweak to all SDL games such that they can be run this way from the dash, just add

SDL_VIDEO_FULLSCREEN_DISPLAY=0

to /etc/environment on a new line and then reboot.

Limbo:

I had a lot more trouble with this game. With dual head enabled the game crashes with a segfault. Normally this can be avoided by running wine in explorer virtual desktop mode (I have to do this with almost any wine game) however, in this came, Limbo is bundled with a custom wine where explorer mode doesn't work. I had to use the distro-supplied wine instead, and then it works correctly, but you have to run it with the normal startup scripts once to get the ~/.limbo directory created, so:

/opt/limbo/launch-limbo.sh - if this works, great, if not:

sudo apt-get install wine1.4

cd ~/.limbo/limbo/drive_c/Program\ Files/limbo/ - you MUST cd or the game will crash

wine explorer /desktop=limbo,1920x1200 limbo.exe - replace 1920x1200 by your desired resolution

To start the application like this when launched form the dash:

sudo gedit /opt/limbo/launch-limbo.sh

comment out the existing code and add:

cd ~/.limbo/limbo/drive_c/Program\ Files/limbo/
wine explorer /desktop=limbo,1920x1200 limbo.exe

Again, replace 1920x1200 by your desired resolution

Bastion

You can launch it in windowed mode at pretty much any resolution by adding options while launching:

cd /opt/bastion/Bastion/
./Bastion.bin.x86_64 -windowed -x 1680 -y 1000

(My monitors have 1680x1050 & I subtracted 50p for the Unity top bar - so its kinda fullscreen)

To launch the game in windowed mode with the dash-shortcut:

cd /opt/bastion/Bastion/
sudo gedit bastion64.sh

And add " -windowed -x 1680 -y 1000" (without quotes, with desired resolutions) after "LD_LIBRARY_PATH=lib64:. ./Bastion.bin.x86_64".

share|improve this answer
    
Thanks for those! –  Uli Jun 2 '12 at 19:16
    
I edited to add a solution for Bastion, hope you don't mind... –  Uli Jun 2 '12 at 19:30
    
Why would you want to run it in a window? –  Alistair Buxton Jun 2 '12 at 21:06
    
So I can multi task (i.e. see incoming email). I didn't actually find a way to run it properly in fullscreen mode (without disabeling a monitor before launching) anyway... –  Uli Jun 2 '12 at 21:56
1  
I think we misunderstood each other. I cant get bastion to run fullscreen properly with nvidia twinview, but it can be run in windowed mode using the command pasted above. When in windowed mode you can multitask by using ALT+TAB. With the other Games multitasking is not possible. –  Uli Jun 3 '12 at 7:16

The solution for Limbo didn't do it for me. What did it for me:

  1. Install wine

  2. Install Directx9

    winetricks directx9
    
  3. Open wine config

    winecfg 
    
  4. Change d3dx9_43 to "(native,builtin)" in Libraries tab

  5. Follow steps in other answer

Taken from “Limbo” game has no sound

Altough it says 'fix for sound' I had to install directx9 to get the game itself running. (and now I even have sound).

share|improve this answer
    
Thanks for this note. I probably already had directx installed from something else. –  Alistair Buxton Jun 4 '12 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.