Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.04 the other day and then ran into trouble upon restarting after installing updates.

What I did before the problem occurred:

I did not make many changes before this problem occurred. Changes I did make included:

  • Downloading and installing Adobe Flash Player (off topic but: I am under the impression that Java, "C&C" and Shockwave can not be run in Ubuntu. Could anybody verify this?)
  • I also installed gnome-tweak-tool and used it to install several themes. These themes worked well until restarting after the update. Is it possible that one of these themes caused the problem (in combination with the update or because of the restart)?
  • Installed 215 updates from update manager and restarted my system.

Current Situation:

Unity 3D is unusable since restarting after running updates. When I log in after entering my password the following things happen:

  1. the overhead panel disappears and the screen goes black for a minute
  2. my wallpaper flashes for a couple seconds but then the screen goes black again
  3. after another minute the wallpaper reappears but nothing else does and I am not able to open anything or even right click.
  4. after 5 minutes I can finally get a right click menu
  5. eventually a box comes up warning about a Compiz failure and asking to let it quit--which I did.

Using the right click functionality I was able to create a new folder on the desktop and use this to open a file browser. In doing so I noticed that the downloads I had made were missing (music, image files, etc., even after unpacking several .zip and .rar files) even though I believe that everything should still be there.

Any new windows that I create are un-closable/minimizable/movable/etc, because the window bars are missing.

I have tried rebooting several times but the results are the same.

I was able to browse some off the System Settings windows by clicking on the wallpaper link in the right click menu.

In doing so I navigated into the update manager and noticed that updates were selected to be accepted from some "unsupported sources". I do not recall setting these options myself and wonder why these--potentially dangerous--options would be selected by default.

Unity 2D is usable but not free of bugs--I stumbled across the ability to log into a Unity 2D session while trying to log into Unity 3D.

So far I have only noticed one bug in Unity 2D: the close, minimize and maximize buttons are invisible--however they are still usable despite being invisible.

What I need:

I'm very new to Linux and Ubuntu and still am in the feeling out stages.

As such I will have some trouble answering clarifying questions.

I haven't used the terminal yet and would probably not be comfortable using it without very clear instructions. What I do need is to know how I can roll back/remove all those updates so I can use my computer regularly again.

I do believe that I could follow step-by-step instructions as long as they are clear and concise if someone knows what my problem is.

share|improve this question
    
If you can use Nautilus at all you better start making backups of anything you need, before continuing to work on the larger problem. Plug in a USB drive and start copying files you don't already have backed up. Also, you didn't install compiz config settings manager (ccsm) by any chance, did you? –  Tom Brossman Jun 2 '12 at 14:44
add comment

2 Answers

So something went obviously wrong during installation of updates. Ubuntu keeps, like Windows and other operating systems, log files for the actions it does. The program involved with the updates is called APT and there should be log files in /var/log/.

You can access these logs by pressing Alt+F2 and typing gedit /var/log/apt/history.log. Please upload them so we can dig into this.

Also please:

  • paste the contents of file /etc/apt/sources.list (Alt+F2 and type gedit /etc/apt/sources.list to view this file)
  • and open a terminal (Ctrl+Alt+T) and upload the output of the command ls -1 /etc/apt/sources.list.d/.
share|improve this answer
    
I heavily edited the original post for readability and civility. The original post probably deserved the downvotes (but they can be removed now). I'm going to edit your answer with explicit instructions on how to get those logs (recognizing that doing so would be time consuming on a phone.) –  adempewolff Jun 2 '12 at 14:52
    
Thanks for you effort. –  LiveWireBT Jun 3 '12 at 11:48
add comment

If you want to uninstall gnome-tweak-tool (that could really be the problem if you changed nothing else):

  1. you have to start the Terminal

    • press ctrl+alt+T to open a terminal window
    • if that doesn't work, drop into a text-only interface by doing this ctrl+alt+F1
    • you can return to the graphical interface by pressingctrl+alt+F7)
  2. Type in sudo apt-get remove gnome-tweak-tool. This might sound strange and new to you, but this will remove the tool.

If this doesn't help and you want to start from scratch:

  1. be sure to backup your personal data and then
  2. restart your computer (with the Ubuntu CD in the tray and your BIOS set to boot from CD). This will boot from the CD and give you the option of re-installing--giving you a clean slate.
share|improve this answer
1  
it should be noted that uninstalling gnome-tweak-tool will not uninstall changes made to the system with it (ie. installed themes). It will just uninstall the GUI for making changes. –  adempewolff Jun 2 '12 at 14:36
    
Oh, right. Then I recommend the reinstall of the system. –  Feratile Jun 2 '12 at 14:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.