Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Greetings from New Zealand.

I have installed Microsoft Windows Vista and then installed Ubuntu 12.04 on my refurbished Compaq nx8220 laptop. I get the following infamous head hurting prompt continually.

error: no such partition.
grub rescue>

Have tried most of the common recommended solutions. Live-CD then install Boot-Repair through the Terminal didn't work. It repaired all the linux stuff when restoring grub and then can't boot into Windows Vista.

When I use Boot-Repair to fix the MBR, then I can't boot into Ubuntu. Tried installing BCD 2.1 in Vista and tried all the options one after another in BCD. Still no Ubuntu when selected through the options menu from BCD on restart/reboot.

I have tried the boot repair option on the Ubuntu server CD-ROM, tried installing earlier versions of Ubuntu 11.04, 11.10, and Ubuntu server 11.10 and 12.04. Still the same result.

I tried deleting the Ubuntu partitions through Vista a number of times and reinstalling Ubuntu.

I have been trying and retrying all the options in Boot-Repair in different combinations for the past week and a half. I have tried at least 10 times installing and reinstalling Ubuntu.

I really love Ubuntu and believe I have exhausted most of the recommended solutions and have spent too much time on this. Its driving me nuts!! please can someone help, I have finally given up (sigh). The following are some outputs from Boot-Repair from my last attempts.

http://paste.ubuntu.com/1019227

http://paste.ubuntu.com/1019264

I was only allowed to post two links being a newbie.

The only thing left for me to do is the flying Samoan dropkick laptop trick.

Thanks in advance.

Francis.

share|improve this question
    
Have you taken a look at this post: ubuntuforums.org/showthread.php?t=1359802 ? –  upapilot Jun 20 '12 at 14:42

2 Answers 2

IF you are attempting to install Ubuntu "within" Ubuntu, you ran into the same problem I did. I then did the installation withing WINDOWS and everything worked perfectly. Try that.

share|improve this answer

You can try contacting the Boot-Repair support team.

Their email appear after using the tool.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.