Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to play Trine, it starts but I get no sound. In the terminal this error message appears:

/o/g/trine> ./trine-launcher64 
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default

I have libasound2-plugins installed, which contains libasound_module_conf_pulse.so, how can I get Trine to recognize it?

I tried starting the 32-Bit version with linux32 as well, it crashes.

share|improve this question
See also this question: askubuntu.com/questions/142956/… –  rakete Jun 2 '12 at 11:27
I can just preload it to make the error message go away, but sound still does not work: env LD_PRELOAD=/usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_conf_pulse.so ./trine-bin64 –  rakete Jun 2 '12 at 11:32

2 Answers 2

up vote 1 down vote accepted

Preloading did solve my problem:

env LD_PRELOAD=/usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_conf_pulse.so  ./trine-launcher

but alsa then played back using the wrong soundcard. Messing around in the sound settings fixed that issue. I don't know why everything else played back fine even if I apparently had the wrong output selected in the sound settings?

share|improve this answer

I run raring 64 bit and solved this issue (no sound) by switching to surroundsound 5.1 as described here https://help.ubuntu.com/community/SurroundSound

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Basharat Sialvi May 8 '13 at 8:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.