Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In 12.04 I cannot use in Unity its default Keyboard layout switching mechanism. It doesn't matter how many and which layouts are added, only keyboard defined in xorgs (or possibly configurable manually using sudo setxkbmap -option grp:alt_shift_toggle "us,cz") appears in system. So what to check why it doesn't work or how to bind setxkbmap directly?

share|improve this question
add comment

1 Answer

To configure keyboard layout manually

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,cz
share|improve this answer
    
As I've written before, I can do this and I did. But I'd like to have a keyboard layout indicator on a panel. ScrollLock led was useful for this on xterm 15 years ago. Unity Keyboard indicator is much better. I'm asking for manual configuration of keyboard indicator or hwo to check why it doesn't work. Thanks. –  Oto 'tapik' Buchta Jun 2 '12 at 16:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.