Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I get ATI Mobility Radeon HD 5450 + Integrated Intel HD to work?

I have Linux 12.04 LTS installed on my HPDV7T laptop (dual booted with windows 7).

My laptop specs are: -Intel Core i7 2620M 2.7 Ghz Dual Core processor -Radeon 6770m graphics card -It is switchable graphics -12 GB ram

I've been trying to get catalyst control center to run, but it has this error:

Initialization error:

There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

No ATI graphics driver is installed, or the ATI driver is not functioning properly. Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig.

Can anyone help? This is the very first time I've used linux, so detailed instructions would be nice. (I do know how to get to the terminal though. And change directory in terminal)

Thanks.

share|improve this question
add comment

marked as duplicate by mikewhatever, jrg Jun 6 '12 at 17:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 2 down vote accepted

I believe that this thread will help you. It has detailed instructions for the installation process and you can seek further help there. As for the error you are experiencing did you do the initial Xserver config via the command in terminal sudo aticonfig --initial -f ?

I hope that helps. By the way I myself own a HP Sandy bridge laptop with discrete 6xx Radeon card. I tried installing the drivers and everything works fine, but when I try to switch from discrete to HD 3000 unity does not load after the reboot. It seems that the Intel card has some problem with Unity/Compiz at start up if the discrete card is enabled. This problem is described on the last pages of the above thread.(You can try and see if it works for you). Good luck.

share|improve this answer
    
Thanks, that worked perfectly! –  Wallace Panter Jun 2 '12 at 15:23
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.