Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Normally, all controls in login screen (button, textbox, etc..) have the current gtk-theme style. But after Compiz crashed (always happen when I enable or disable a plugin), the style has gone (no more transparent button, rounder textbox, or my current icon theme), instead there are ugly windows-95-like buttons, textbox and unknown-theme icon.

Is this a compiz bug? How could I fix it?

Thanks for your time! PS: Im on Ubuntu 12.04 (Unity).

This is my Ubuntu login screen:

The textbox and button are squared

enter image description here

This is default ubuntu login screen:

enter image description here

enter image description here

Im on Dell Vostro 1540 with Intel HD 3000 VGA. At first, my login screen looks nothing wrong. But after compiz crashed (when I enable or disable any plugin), the login screen looks like the above pictures. So, I dont think my graphics card is the problem.

share|improve this question
add comment

1 Answer 1

I also had a similar problem with unity.I guess that is a problem with your graphics card.Compiz has problems supporting the 82G965 Chipset.

You can try to revive the menubar's look with the following command:

killall gnome-settings-daemon
gnome-settings-daemon &

On the other hand,try to login from the Ubuntu Classic Session,then install Unity 2D and then login again from the Unity 2D Session.

share|improve this answer
    
I tried it but had no luck. Do I need to re-install LightDM? How to do that? –  quangtruong1985 Jun 6 '12 at 3:43
    
Maybe you do not have that graphics card.What is your graphics card model and chipset anyway? –  Nickolas Jun 6 '12 at 9:31
    
Im on Dell Vostro 1540 with Intel HD 3000 VGA. At first, my login screen looks nothing wrong. But after compiz crashed (when I enable or disable any plugin), the login screen looks like the above pictures. So, I dont think my graphics card is the problem. –  quangtruong1985 Jun 6 '12 at 11:23
    
Take a look at this article webupd8.org/2011/06/… –  Nickolas Jun 6 '12 at 11:43
    
I tried to add 20 seconds before running gnome-settings-daemon but had no luck. It just delayed 20s, then show my desktop. But nothing change in login screen. –  quangtruong1985 Jun 7 '12 at 13:03
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.