Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want Ubuntu to always use Unity2D by default. I am using the latest version (12.04 LTS).

share|improve this question
    
can some one please answer to this quickly.. From Arun –  Arun Jun 2 '12 at 5:21
    
Does it not remember the last session, and start that automatically? Or are you saying you want to start 2d no matter which one you last used? There is some discussion on how to change the default here –  Marty Fried Jun 2 '12 at 5:31
add comment

3 Answers 3

when logging in there is a symbol in the top right of the box (usually a ubuntu logo unless using something else) click on the logo and then click ubuntu 2D , if you dont change this , you will always log into unity 2d

share|improve this answer
add comment

To set the default for all users, you can use

sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu-2d

or you can edit the file /etc/lightdm/lightdm.conf directly. See this documented version.

Per-user settings are stored in either $HOME/.dmrc or in /var/lib/AccountsService/users/$USER . According to this post, the latter file may overwrite your .dmrc.

share|improve this answer
add comment

Just log-in unity-2d, under System Settings -> User Account, unlock and enable Automatic Login.

My ubuntu 12.04 enables auto-login while installation. It auto-login last session I logged in.

share|improve this answer
3  
This question is about making Unity2D the default session. Also enabling auto-login is not part of the question. –  WarriorIng64 Jun 2 '12 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.