Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On normal working with nothing opened, compiz fires up to 50% CPU usage on my machine. Which is abnormal I think.

Is this a bug or is this behavior ok?

I am running Ubuntu 12.04 on Intel i5 processor
ATI 5400 mobility 512 MB Graphic card

share|improve this question
    
Can you provide the output of glxinfo | grep render? –  Samik Jun 2 '12 at 5:23
    
direct rendering: Yes OpenGL renderer string: ATI Mobility Radeon HD 5000 Series GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render, –  shubham Jun 2 '12 at 5:47
    
There a quite a few reports on this, e.g. bug #803943 and more... –  Takkat Jun 2 '12 at 8:52
    
nope, it is not at all okay –  virpara Jun 2 '12 at 9:19
    
Ok, so your graphics chipset is recognised and video driver is loaded, one possible reason could be if the software renderer is used, then compiz might cause high CPU usage. But clearly that is not the case here. –  Samik Jun 2 '12 at 14:47
show 1 more comment

1 Answer

Had the same problem. Compiz constantly at around 40% (AMD CPU, ATI 58xx, 12.04). Then i followed this post http://askubuntu.com/a/127310/26508 and CPU utilization dropped below 10%. Hope it helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.