Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

Unity is gone. As I have use user defined session on 12.04, I'm back to default sesion (ubuntu) and then unity is gone, how to reveal it.

How to get to Compiz without that unity taskbar? Even Ubuntu 3D on top missing. On Ubuntu 2d it appears fine. help me to reveal it.

share|improve this question

marked as duplicate by jokerdino, Jorge Castro, Mitch, Tom Brossman, Ringtail Sep 11 '12 at 3:32

This question was marked as an exact duplicate of an existing question.

Try following some of these instructions:

Hope this helps,


share|improve this answer

right click at that desktop of unity and create a folder and open it . then move to filesystem > usr > bin > applications . there you can find compiz settings manager . open it and enable the unity plugin and restart .

else try as ctrl+ Alt+F1 then login there and type as unity --reset then restart your pc.

share|improve this answer
are you sure, that he installed compizconfig-settings-manager. It wasn't installed by default – Anwar Shah Jun 24 '12 at 15:19
but he mentioned asa wanna get to compiz , means installled – Raja Jun 24 '12 at 15:21
compiz is installed by default, but not compizconfig-settings-manager. You can check that by running a Live CD – Anwar Shah Jun 24 '12 at 15:25

as well just go to unity 2D and go to Compiz, setting, & then plugin list. you lost that because you/I: remove: -unityshell, & -unitymtgrabhandles. so put that back but lost all the setting include the transparency. so............. I need MyUnity on software center to fix that configuration (WHAT?! tired...!)

share|improve this answer
so we may not sad to this. we can rebuild it again, except the school. so..., we need approx 2 month to remind it again except for who is high IQ just need 12 hours when holiday but with resisted of school such homework, we need 2 year (actualy when final test). – Joel Robert Jun 24 '12 at 15:15

If you actually get chance to log into the desktop (though not working unity), Opening a terminal and doing unity --reset will do the job.


  • Open a terminal by pressing CTRL + ALT + T
  • Type unity --reset to reset the Unity settings.
  • Then type unity to start unity.
  • Then without closing the terminal, Logout from session and then Login again.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.